Home / Node / PwnKit: escalada de privilegios local en PolKit afecta a distribuciones Linux

PwnKit: escalada de privilegios local en PolKit afecta a distribuciones Linux

Publication date: 
01/28/2022
Importance: 
4 - Alta
Affected resources: 

La vulnerabilidad se encuentra en el componente pkexec de PolKit, que está en la configuración por defecto de la mayoría de distribuciones Linux.

Todas las versiones de PolKit desde la primera introducción de pkexec son vulnerables; es decir, desde la versión 0.113 del año 2009.

Todas las distribuciones Major de Linux, inluyendo Ubuntu, Debian, Fedora y CentOS, se ven afectadas, ya que PolKit (antes PolicyKit) es un sistema para la gestión de permisos ampliamente usado en Linux.

Description: 

El equipo de investigación de Qualys ha descubierto una vulnerabilidad de corrupción de memoria en el componente pkexec de PolKit, un binario SUID-root con una funcionalidad similar a sudo, y que se instala por defecto en las principales distribuciones de Linux.

Esta vulnerabilidad podría permitir a un usuario no privilegiado obtener privilegios de root en un host vulnerable, aprovechando esta vulnerabilidad en su configuración por defecto.

Solution: 

Actualizar todas las distribuciones de Linux que proporcionan un backport de la corrección (reinicio necesario):

  • Ubuntu 14.04 y 16.04 ESM.
  • Ubuntu 18.04, 20.04 y 21.04.
  • RedHat en productos Workstation y Enterprise para arquitecturas soportadas, así como para el apoyo al ciclo de vida ampliado, TUS y AUS.
  • Debian Stretch, Buster, Bellseye, unstable.

Como medida de mitigación temporal se puede ejecutar el siguiente comando:

chmod 0755 /usr/bin/pkexec
Detail: 

Se trata de una vulnerabilidad de corrupción de memoria causada por la forma en que los argumentos son leídos por el componente pkexec de PolKit. Esto permitiría reintroducir en el entorno de pkexec una variable de entorno insegura, que podría permitir la ejecución de librerías arbitrarias, y que normalmente se eliminaría antes de la ejecución del programa. Se ha asignado el identificador CVE-2021-4034 para esta vulnerabilidad.

Destaca su facilidad de explotación, ya que es suficiente con manipular las variables de entorno, sin necesidad de eludir protecciones.

IMPORTANTE: esta vulnerabilidad está siendo explotada activamente.

Encuesta valoración