Home / Node / Múltiples vulnerabilidades en productos Codesys

Múltiples vulnerabilidades en productos Codesys

Publication date: 
05/27/2021
Importance: 
5 - Crítica
Affected resources: 
  • Todos los sistemas de ejecución de CODESYS V3 que contienen el CmpWebServer en todas las versiones anteriores a la V3.5.17.10 están afectados, independientemente del tipo de CPU o del sistema operativo:
    • CODESYS Control RTE V3,
    • CODESYS Control RTE V3 (para Beckhoff CX),
    • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System),
    • CODESYS HMI V3,
    • CODESYS Control V3 Runtime System Toolkit,
    • CODESYS V3 Embedded Target Visu Toolkit,
    • CODESYS V3 Remote Target Visu Toolkit.
  • Los siguientes productos basados en CODESYS Control V3 Runtime System Toolkit están afectados en todas las versiones anteriores a V4.2.0.0:
    • CODESYS Control para BeagleBone SL,
    • CODESYS Control para emPC-A/iMX6 SL,
    • CODESYS Control para IOT2000 SL,
    • CODESYS Control para Linux SL,
    • CODESYS Control para PLCnext SL,
    • CODESYS Control para PFC100 SL,
    • CODESYS Control para PFC200 SL,
    • CODESYS Control para Raspberry Pi SL,
    • CODESYS Control para WAGO Touch Panels 600 SL.
  • Todas las versiones del CODESYS V3 Runtime Toolkit para VxWorks desde la versión V3.5.8.0 hasta la anterior a V3.5.17.10.
Description: 

Device Security Assurance Center de ABB ha notificado 2 vulnerabilidades, una crítica y otra alta, de tipo desbordamiento de búfer basado en montículo (heap) y gestión incorrecta de condiciones excepcionales, respectivamente.

Solution: 
  • CODESYS GmbH ha lanzado la versión V3.5.16.50, que soluciona la vulnerabilidad identificada en los siguientes productos para versiones anteriores a V3.5.17.0 (también será solucionado por la versión V3.5.17.10, planeada para julio de 2021):
    • CODESYS Control RTE V3,
    • CODESYS Control RTE V3 (para Beckhoff CX),
    • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System),
    • CODESYS HMI V3,
    • CODESYS Control V3 Runtime System Toolkit,
    • CODESYS V3 Embedded Target Visu Toolkit,
    • CODESYS V3 Remote Target Visu Toolkit.
  • La vulnerabilidad se solucionará con la versión V4.2.0.0, que se basa en CODESYS Control V3 Runtime System Toolkit V3.5.17.10, planeada para agosto de 2021:
    • CODESYS Control for BeagleBone SL,
    • CODESYS Control for emPC-A/iMX6 SL,
    • CODESYS Control for IOT2000 SL,
    • CODESYS Control for Linux SL,
    • CODESYS Control for PLCnext SL,
    • CODESYS Control for PFC100 SL,
    • CODESYS Control for PFC200 SL,
    • CODESYS Control for Raspberry Pi SL,
    • CODESYS Control for WAGO Touch Panels 600 SL.
Detail: 
  • El servidor web de CODESYS es utilizado por CODESYS WebVisu para mostrar las pantallas de visualización de CODESYS en un navegador web. El envío de solicitudes, específicamente diseñadas, podrían causar un desbordamiento de búfer basado en montículo (heap). Esta situación podría bloquear el servidor web, conducir a una condición de denegación de servicio o ser utilizado para la ejecución remota de código. Como el servidor web es parte del sistema de ejecución de CODESYS, la explotación podría conllevar un comportamiento imprevisto del sistema de ejecución completo. Se ha asignado el identificador CVE-2021-33485 para esta vulnerabilidad crítica.
  • La capa de adaptación a la plataforma de CODESYS V3 Runtime Toolkit para VxWorks no gestiona correctamente la escasez de sockets, por lo que las conexiones de socket existentes podrían desconectarse y no restablecerse durante algún tiempo. Se ha asignado el identificador CVE-2021-33486 para esta vulnerabilidad alta.

Encuesta valoración