Inicio / Content / Boletín de vulnerabilidades

Boletín de vulnerabilidades

Nuevas vulnerabilidades documentadas a los productos que usted está suscrito:

Vulnerabilidad en un modelo guardado en el uso de valores no inicializados en TensorFlow (CVE-2020-26266)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En las versiones afectadas de TensorFlow, en determinados casos, un modelo guardado puede activar el uso de valores no inicializados durante la ejecución del código. Esto es debido a que los búferes de tensor se llenan con el valor predeterminado del tipo, pero se olvidan de inicializar por defecto los tipos de punto flotante cuantificados en Eigen. Esto es corregido en las versiones 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 y 2.4.0.
Vulnerabilidad en la operación tf.raw_ops.ImmutableConst en TensorFlow (CVE-2020-26268)
Gravedad:
BajaBaja
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En las versiones afectadas de TensorFlow, la operación tf.raw_ops.ImmutableConst devuelve un tensor constante creado a partir de un archivo mapeado en memoria que se asume inmutable. Sin embargo, si el tipo de tensor no es un tipo integral, la operación bloquea el intérprete de Python cuando intenta escribir en el área de la memoria. Si el archivo es muy pequeño, TensorFlow devuelve apropiadamente un error ya que el área de la memoria posee menos bytes de los necesarios para el tensor que crea. Sin embargo, tan pronto como haya suficientes bytes, el fragmento anterior causa un fallo de segmentación. Esto es debido a que el asignador usado para devolver los datos del búfer no está marcado como devolviendo un identificador opaco, ya que el método virtual necesario no se anula. Esto es corregido en las versiones 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 y 2.4.0.
Vulnerabilidad en la implementación paralela de GetMatchingPaths en TensorFlow (CVE-2020-26269)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En las versiones candidatas a lanzamiento de TensorFlow 2.4.0rc*, la implementación general para hacer coincidir las rutas del sistema de archivos con el patrón globbing es vulnerable a un acceso fuera de límites de la matriz que contiene los directorios. Existen múltiples invariantes y condiciones previas que son asumidas por la implementación paralela de GetMatchingPaths pero no son verificadas por los RP que lo presentan (#40861 y #44310). Por lo tanto, estamos reescribiendo completamente la implementación para especificarlos y validarlos completamente. Esto está parcheado en la versión 2.4.0. Este problema solo afecta a la rama maestra y a los candidatas de lanzamiento para TF versión 2.4. La versión final de la versión 2.4 será parcheada.
Vulnerabilidad en un modelo LSTM/GRU en la capa LSTM/GRU en TensorFlow (CVE-2020-26270)
Gravedad:
BajaBaja
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En las versiones afectadas de TensorFlow que ejecutan un modelo LSTM/GRU donde la capa LSTM/GRU recibe una entrada con longitud cero, se produce un fallo de COMPROBACIÓN cuando se usa el backend CUDA. Esto puede resultar en una vulnerabilidad query-of-death, por medio de la denegación de servicio, si los usuarios pueden controlar la entrada a la capa. Esto es corregido en las versiones 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 y 2.4.0.
Vulnerabilidad en la función MakeEdge en TensorFlow (CVE-2020-26271)
Gravedad:
BajaBaja
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En las versiones afectadas de TensorFlow en determinados casos, cargar un modelo guardado puede resultar en el acceso a la memoria no inicializada mientras se construye el gráfico de computación. La función MakeEdge crea un perímetro entre un tensor de salida del nodo src (dado por output_index) y la ranura de entrada del nodo dst (dado por input_index). Esto solo es posible si los tipos de tensores en ambos lados coinciden, por lo que la función comienza obteniendo los valores de DataType correspondientes y comparándolos para la igualdad. Sin embargo, no se comprueba que los índices apunten al interior de las matrices en las que indexan. Por lo tanto, esto puede resultar en un acceso a datos fuera de límites de los correspondientes arreglos asignados a la pila. En la mayoría de los escenarios, esto puede manifestarse como un acceso a los datos no inicializados, pero si el índice apunta lejos de los límites de las matrices, esto se puede usar para filtrar direcciones de la biblioteca. Esto es corregido en las versiones 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 y 2.4.0.
Vulnerabilidad en /websocket/logs/ en Lan ATMService M3 ATM Monitoring System (CVE-2020-29666)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En Lan ATMService M3 ATM Monitoring System versión 6.1.0, debido a una vulnerabilidad de listado de directorios, un atacante remoto puede visualizar archivos de registro, ubicados en /websocket/logs/, que contienen los valores de las cookies de un usuario y el valor de las cookies del desarrollador predefinido.
Vulnerabilidad en la Expiración de Sesión en Lan ATMService M3 ATM Monitoring System (CVE-2020-29667)
Gravedad:
AltaAlta
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
En Lan ATMService M3 ATM Monitoring System versión 6.1.0, un atacante remoto capaz de usar un valor de cookie predeterminado, como PHPSESSID=LANIT-IMANAGER, puede lograr el control sobre el sistema debido a una Expiración de Sesión Insuficiente.
Vulnerabilidad en SMG (CVE-2020-12595)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
Un fallo en la divulgación de información permite a un usuario de Interfaz de Usuario web privilegiado, autenticado y malicioso obtener una contraseña para un servidor de respaldo SCP remoto al que de otra manera no estaría autorizado en acceder. Esto afecta a SMG versiones anteriores a 10.7.4.
Vulnerabilidad en el add-on AEM Forms SP6 para AEM y el paquete add-on Forms para AEM (CVE-2020-24444)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
14/12/2020
Descripción:
El add-on AEM Forms SP6 para AEM versión 6.5.6.0 y el paquete add-on Forms para AEM versión 6.4 Service Pack versión 8 Cumulative Fix Pack versión 2 (6.4.8.2), presentan una vulnerabilidad ciega de tipo Server-Side Request Forgery (SSRF). Esta vulnerabilidad podría ser explotada por un atacante no autenticado para recopilar información sobre los sistemas internos que residen en la misma red.
Vulnerabilidad en los archivos apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc en el análisis de paquetes .deb en APT (CVE-2020-27350)
Gravedad:
MediaMedia
Publication date: 10/12/2020
Last modified:
08/01/2021
Descripción:
APT tuvo varios desbordamientos y subdesbordamientos de enteros al analizar paquetes .deb, también se conocen como GHSL-2020-168 GHSL-2020-169, en los archivos apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. Este problema afecta: apt versiones 1.2.32ubuntu0 anteriores a 1.2.32ubuntu0.2; versiones 1.6.12ubuntu0 anteriores a 1.6.12ubuntu0.2; versiones 2.0.2ubuntu0 anteriores a 2.0.2ubuntu0.2; versiones 2.1.10ubuntu0 anteriores a 2.1.10ubuntu0.1;

Otras vulnerabilidades de los productos a los que usted está suscrito, y cuya información ha sido actualizada recientemente:

Vulnerabilidad en campos de formulario en el navegador en una oferta de Cloud Service de AEM (CVE-2020-24445)
Gravedad:
BajaBaja
Publication date: 10/12/2020
Last modified:
13/01/2021
Descripción:
Una oferta de Cloud Service de AEM, así como las versiones 6.5.6.0 (y anteriores), están afectadas por una vulnerabilidad de tipo Cross-Site Scripting (XSS) almacenado que podría ser abusada por un atacante para inyectar scripts maliciosos en campos de formulario vulnerables. Puede ser ejecutado JavaScript malicioso en el navegador de una víctima cuando navega en la página que contiene el campo vulnerable