Inicio / Content / Boletín de INCIBE-CERT del 31-01-2022

Boletín de INCIBE-CERT del 31-01-2022

Ejecución remota de código en OPC server de ABB

Fecha de publicación: 
31/01/2022
Importancia: 
4 - Alta
Recursos afectados: 
  • 800xA, Control Software para AC 800M1:
    • OPC Server para AC 800M, versiones 5.1.0-x, 5.1.1-x, 6.0.0-1 a 6.0.0-3.
  • Control Builder Safe, versiones 1.x and 2.0 including:
    • OPC Server para AC 800M, versiones 5.1.1-1 and 6.0.0-1.
  • Compact Product Suite - Control and I/O:
    • OPC Server para AC 800M, versiones: 5.1.0-x, 5.1.1-x, 6.0.0-x.
Descripción: 

ABB ha publicado una vulnerabilidad de severidad alta por la que un atacante remoto, autenticado con bajos privilegios, podría insertar y ejecutar código arbitrario en servidor OPC.

Solución: 

Actualizar 800xA, Control Software para AC 800M a:

  • versión 6.1.0-0 o superior;
  • 6.0.0-4 (próxima versión).
Detalle: 

Existe una vulnerabilidad en el Servidor OPC de ABB, para el AC 800M incluido en las versiones del producto mencionadas, que podría permitir a un atacante remoto, autenticado con bajos privilegios, insertar y ejecutar código arbitrario. Se ha asignado el identificador CVE-2021-22284 para esta vulnerabilidad.

Encuesta valoración