Inicio / Content / Boletín de INCIBE-CERT del 21-09-2021

Boletín de INCIBE-CERT del 21-09-2021

Múltiples vulnerabilidades en Moodle

Fecha de publicación: 
21/09/2021
Importancia: 
5 - Crítica
Recursos afectados: 

Las versiones de Moodle que se ven afectadas son las siguientes:

  • de la 3.11 a la 3.11.2,
  • de la 3.10 a la 3.10.6,
  • de la 3.9 a la 3.9.9 y
  • versiones anteriores sin soporte.
Descripción: 

Se han publicado cuatro vulnerabilidades de severidad crítica y otra de severidad baja que podrían permitir a un atacante realizar un secuestro de sesión o acceder a información confidencial.

Solución: 

Actualizar a las versiones:

  • 3.11.3,
  • 3.10.7 y
  • 3.9.10.
Detalle: 
  • El plugin de autenticación Shibboleth es vulnerable al secuestro de sesión si está habilitado. Se ha asignado el identificador CVE-2021-40691 para esta vulnerabilidad crítica.
  • Un atacante podría eludir la autenticación al utilizar una base de datos externa para autenticación debido a una vulnerabilidad de tipo juggling (comparar valores aunque tengan un tipo de datos diferente). Se ha asignado el identificador CVE-2021-40693 para esta vulnerabilidad crítica.
  • Un atacante con privilegios de administrador podría leer los archivos alojados en el servidor HTTP de una cuenta a través del preámbulo de LaTeX. Se ha asignado el identificador CVE-2021-40694 para esta vulnerabilidad crítica.
  • La calificación de una prueba podría ser leída previamente a su publicación mediante el uso de un servicio web de prueba. Se ha asignado el identificador CVE-2021-40695 para esta vulnerabilidad crítica.

Para la vulnerabilidad de severidad baja, se ha asignado el identificador CVE-2021-40692.

Encuesta valoración