Inicio / Content / Boletín de INCIBE-CERT del 20-11-2019

Boletín de INCIBE-CERT del 20-11-2019

Múltiples vulnerabilidades en productos de Moxa

Fecha de publicación: 
20/11/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • EDS-G508E Series, versión 6.0 y anteriores,
  • EDS-G512E Series, versión 6.0 y anteriores,
  • EDS-G516E Series, versión 6.0 y anteriores,
  • EDR-810 Series, versión 5.1 y anteriores.
Descripción: 

Los investigadores Yuval Ardon y Matan Dobrushin, de Otorio, junto con Neil Pope y Rhys Cable, de Motherwell Avanced Technologies Cyber Review Team, han reportado vulnerabilidades con severidades críticas en productos de Moxa. Un atacante remoto podría dejar el dispositivo fuera de servicio, generar una condición de denegación de servicio o la ejecución arbitraria de comandos.

Solución: 

Moxa ha publicado actualizaciones que mitigan las vulnerabilidades:

Detalle: 
  • La vulnerabilidad reside en los paquetes de descubrimiento de dispositivos PROFINET DCE-RPC. Un atacante remoto podría inutilizar o generar una condición de denegación de servicio en el dispositivo.
  • La falta de saneamiento en elementos especiales empleados en la interfaz de usuario web (Web GUI) podría permitir a un atacante remoto, mediante una petición HTTP POST, específicamente creada, realizar una ejecución arbitraria de comandos. Se ha reservado el identificador CVE-2019-14374 para esta vulnerabilidad.

Encuesta valoración

Múltiples vulnerabilidades en FlexNet Publisher de Flexera

Fecha de publicación: 
20/11/2019
Importancia: 
5 - Crítica
Recursos afectados: 

FlexNet Publisher, versión 2018 R3 y anteriores.

Descripción: 

El investigador Sergey Temnikov, de Kaspersky, ha reportado vulnerabilidades de tipo validación de entradas incorrecta y corrupción de memoria que afectan a FlexNet Publisher de Flexera. La explotación exitosa de estas vulnerabilidades podría permitir a un atacante remoto negar la adquisición de una licencia válida para el uso legal del producto y la ejecución de código de forma remota.

Solución: 

Flexera recomienda actualizar a la versión 2018 R4 o superior.

Detalle: 
  • Varias vulnerabilidades relacionadas con la eliminación preventiva de elementos, la decodificación de mensajes o la adición de un elemento a una lista en los componentes lmgrd y daemon del proveedor permite que un atacante remoto envíe una combinación de mensajes a lmgrd o a daemon, haciendo que el heartbeat entre lmgrd y daemon del proveedor se detenga y que el daemon se apague. Se han asignado los identificadores CVE-2018-20031, CVE-2018-20032 y CVE-2018-20034 para estas vulnerabilidades, respectivamente.
  • Una vulnerabilidad en los componentes lmgrd y daemon del proveedor podría permitir que un atacante remoto corrompa la memoria asignando/desasignando memoria, cargando lmgrd o daemon, y causando que el heartbeat entre lmgrd y daemon se detenga. Esto obligaría al demonio del vendedor a cerrar. Esta vulnerabilidad también podría permitir la ejecución remota de código. Se ha asignado el identificador CVE-2018-20033 para esta vulnerabilidad.

Encuesta valoración

Vulnerabilidad en el servidor web de CODESYS de 3S-Smart Software Solutions GmbH

Fecha de publicación: 
20/11/2019
Importancia: 
5 - Crítica
Recursos afectados: 

Todos los sistemas en tiempo de ejecución de CODESYS V3 que contienen el servidor web (CmpWebServer y CmpWebServerHandler) en todas las versiones anteriores a 3.5.15.20 se ven afectados, independientemente del tipo de CPU o sistema operativo:

  • CODESYS Control para BeagleBone;
  • CODESYS Control para emPC-A/iMX6;
  • CODESYS Control para IOT2000;
  • CODESYS Control para Linux;
  • CODESYS Control para PLCnext;
  • CODESYS Control para PFC100;
  • CODESYS Control para PFC200;
  • CODESYS Control para Raspberry Pi;
  • CODESYS Control RTE V3;
  • CODESYS Control RTE V3 (para Beckhoff CX);
  • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System);
  • CODESYS HMI V3;
  • CODESYS Control V3 Runtime System Toolkit;
  • CODESYS V3 Embedded Target Visu Toolkit;
  • CODESYS V3 Remote Target Visu Toolkit.
Descripción: 

Un cliente de OEM y Tenable ha reportado una vulnerabilidad, de tipo desbordamiento de búfer basado en memoria dinámica (heap), que afecta a sistemas Codesys V3. La explotación exitosa de esta vulnerabilidad podría permitir a un atacante remoto causar una denegación de servicio o la ejecución de código arbitraria.

Solución: 

3S-Smart Software Solutions GmbH ha publicado la versión 3.5.15.20 para solucionar esta vulnerabilidad.

Detalle: 

El servidor web de CODESYS es utilizado por CODESYS WebVisu para mostrar las pantallas de visualización de CODESYS en un navegador web. El envío de solicitudes, específicamente diseñadas, puede causar un desbordamiento de búfer basado en memoria dinámica (heap). Más adelante, esto podría bloquear el servidor web, provocar una condición de denegación de servicio o puede ser utilizado para la ejecución remota de código. Dado que el servidor web forma parte del sistema de tiempo de ejecución de CODESYS, esto puede dar lugar a un comportamiento imprevisto del sistema de ejecución por completo. Se ha reservado el identificador CVE-2019-18858 para dicha vulnerabilidad.

Encuesta valoración