Inicio / Content / Boletín de INCIBE-CERT del 18-09-2020

Boletín de INCIBE-CERT del 18-09-2020

Múltiples vulnerabilidades en Philips Clinical Collaboration Platform

Fecha de publicación: 
18/09/2020
Importancia: 
3 - Media
Recursos afectados: 

Clinical Collaboration Platform versión 12.2.1 y anteriores.

Descripción: 

Investigadores del Northridge Hospital Medical Center han reportado varias vulnerabilidades en Clinical Collaboration Platform que podrían permitir a un atacante causar una denegación de servicio (DoS), engañar a un usuario y ejecutar un ataque Cross-site Request Forgery (CSRF) o proporcionar información para otros ataques posteriores.

Solución: 

Actualizar Clinical Collaboration Platform a la versión 12.2.5 para solucionar varias vulnerabilidades y el parche 12.2.1.5 para el resto de vulnerabilidades. La vulnerabilidad CVE-2020-16200 requiere la intervención manual para solucionarse.

Los usuarios de Clinical Collaboration Platform pueden contactar con el servicio de soporte regional, o llamar al 1-877-328-2808.

Detalle: 

Las vulnerabilidades más importantes reportadas en Clinical Collaboration Platform se refieren a la exposición de un recurso con un control incorrecto proporcionando información a un atacante para un acceso inadecuado al recurso. Para esta vulnerabilidad se ha reservado el identificador CVE-2020-16247.

La otra vulnerabilidad más importante se refiere a una falta de control en la asignación de un recurso limitado, lo que puede utilizarse por un atacante para alterar los recursos consumidos y potencialmente causar una denegación de servicio. Para esta vulnerabilidad se ha reservado el identificador CVE-2020-16200.

Para otras vulnerabilidades detectadas se han reservado los identificadores CVE-2020-16198,  CVE-2020-14525 y CVE-2020-14506.

Encuesta valoración

Múltiples vulnerabilidades en CodeMeter de Wibu Systems

Fecha de publicación: 
18/09/2020
Importancia: 
5 - Crítica
Recursos afectados: 

Las siguientes versiones de CodeMeter Runtime, un administrador de licencias, se ven afectadas:

  • todas las versiones anteriores a 7.10a están afectadas por CVE-2020-14509, CVE-2020-14517 y CVE-2020-14519;
  • todas las versiones anteriores a 7.10 están afectadas por CVE-2020-16233;
  • todas las versiones anteriores a 6.81 están afectadas por CVE-2020-14513;
  • todas las versiones anteriores a 6.90 están afectadas por CVE-2020-14515 cuando se utilizan archivos de actualización CmActLicense con CmActLicense Firm Code.
Descripción: 

Los investigadores, Sharon Brizinov y Tal Keren, de Claroty, han reportado 6 vulnerabilidades, 2 con severidad crítica y 4 altas, de tipo acceso al búfer con valor de longitud incorrecto, fortaleza de cifrado inadecuada, error de validación de origen, validación incorrecta de datos de entrada, verificación incorrecta de firma criptográfica y liberación de recursos inapropiados.

Solución: 

Wibu Systems recomienda tomar las siguientes medidas:

  • actualizar a la última versión CodeMeter Runtime,
  • ejecutar CodeMeter Runtime solo como cliente,
  • utilizar la nueva API REST en lugar de la API interna de WebSockets,
  • deshabilitar la API de WebSockets,
  • aplicar AxProtector.

Para información más detallada de los avisos que han publicado los distintos fabricantes afectados por estas vulnerabilidades, consultar la sección 5. MITIGATIONS del aviso de CISA.

Detalle: 
  • Existen múltiples vulnerabilidades de memoria corrupta, donde el mecanismo del analizador de paquetes no verifica los campos de longitud. Un atacante podría enviar paquetes, especialmente diseñados, para aprovechar estas vulnerabilidades. Se ha asignado el identificador CVE-2020-14509 para esta vulnerabilidad.
  • El cifrado del protocolo se puede vulnerar fácilmente y el servidor acepta conexiones externas, lo que podría permitir que un atacante se comunique de forma remota con la API de CodeMeter. Se ha asignado el identificador CVE-2020-14517 para esta vulnerabilidad.
  • Esta vulnerabilidad podría permitir que un atacante utilizara la API interna de WebSockets, a través de un payload de Java Script específicamente diseñado, que permitiría la alteración o creación de archivos de licencia, al combinarse con la vulnerabilidad CVE-2020-14515. Se ha asignado el identificador CVE-2020-14519 para esta vulnerabilidad.
  • CodeMeter y el software que lo usa podrían procesar erróneamente un archivo de licencia, específicamente diseñado, debido a campos de longitud no verificados. Se ha asignado el identificador CVE-2020-14513 para esta vulnerabilidad.
  • Existe un problema en el mecanismo de verificación de la firma del archivo de licencia, que podría permitir a los atacantes crear archivos de licencia arbitrarios. Se ha asignado el identificador CVE-2020-14515 para esta vulnerabilidad.
  • Un atacante podría enviar un paquete, especialmente diseñado, que podría causar que el servidor devuelva paquetes que contengan datos del montículo (heap). Se ha asignado el identificador CVE-2020-16233 para esta vulnerabilidad.

Encuesta valoración

Vulnerabilidad en WebAccess Node de Advantech

Fecha de publicación: 
18/09/2020
Importancia: 
4 - Alta
Recursos afectados: 

WebAccess Node, todas las versiones anteriores a la 9.0.1.

Descripción: 

Se ha publicado una vulnerabilidad de severidad alta en WebAccess Node de Advantech que podría permitir a un atacante la escalada de privilegios.

Solución: 

Actualizar a la versión 9.0.1.

Detalle: 

El producto afectado no cuenta con los permisos adecuados para los recursos utilizados por servicios específicos lo que podría permitir la ejecución de código. Se ha reservado el identificador CVE-2020-16202 para esta vulnerabilidad.

Encuesta valoración