Inicio / Content / Boletín de INCIBE-CERT del 16-08-2019

Boletín de INCIBE-CERT del 16-08-2019

Desbordamiento de búfer en Alpha5 Smart Loader de Fuji Electric

Fecha de publicación: 
16/08/2019
Importancia: 
4 - Alta
Recursos afectados: 
  • Alpha5 Smart Loader, todas las versiones anteriores a la 4.2.
Descripción: 

El investigador Natnael Samson, trabajando de manera conjunta con Trend Micro’s Zero Day Initiative, ha reportado una vulnerabilidad de tipo desbordamiento de búfer en el software Alpha5 Smart Loader, que podría permitir, a un atacante, la ejecución de código con los mismos privilegios que tenga la aplicación.

Solución: 

Actualizar a la versión 4.2

Detalle: 

Un atacante podría manipular el fichero del proyecto de manera malintencionada para provocar el desbordamiento de búfer en la aplicación Alpha5 Smart Loader, para ejecutar código bajo los privilegios con los que se esté ejecutando dicha aplicación. Se ha reservado el identificador CVE-2019-13520 para esta vulnerabilidad.

Encuesta valoración

Etiquetas: 

Múltiples vulnerabilidades en los sistemas Metasys building automation de Johnson Controls

Fecha de publicación: 
16/08/2019
Importancia: 
3 - Media
Recursos afectados: 
  • Sistema de automatización Metasys building automation, todas las versiones anteriores a la 9.0
Descripción: 

El investigador harpocrates.ghost ha reportado varias vulnerabilidades  de tipo reutilización de claves de encriptación y claves embebidas en código, que podrían permitir a un atacante remoto, descifrar las comunicaciones de red, afectando a la confidencialidad de las mismas.

Solución: 

El fabricante Johnson Controls, recomienda actualizar a versiones posteriores a la v9.0 y configurar las comunicaciones para utilizar certificados de confianza.

Detalle: 
  • Los servidores ADS/ADX de Metasys y los motores NAE/NIE/NCE, comparten ciertas claves de cifrado RSA utilizadas para la operación contra el Site Management Portal (SMP). Un atacante con acceso a estas claves compartidas RSA, podría descifrar las comunicaciones, tanto de los servidores ADS/ADX como de los NAE/NIE/NCE, realizadas contra el cliente SMP. Se ha asignado el identificador CVE-2019-7593 para esta vulnerabilidad.
  • Los servidores ADS/ADX de Metasys y los motores NAE/NIE/NCE, utilizan claves RC2 embebidas para ciertas operaciones contra el Site Management Portal (SMP). Un atacante con acceso a estas claves embebidas RC2, podría descifrar las comunicaciones realizadas entre los servidores ADS/ADX como de los motores NAE/NIE/NCE, realizadas contra el cliente SMP. Se ha asignado el identificador CVE-2019-7594 para esta vulnerabilidad.

Encuesta valoración