Inicio / Content / Boletín de INCIBE-CERT del 13-06-2022

Boletín de INCIBE-CERT del 13-06-2022

Múltiples vulnerabilidades en el core de Drupal 9

Fecha de publicación: 
13/06/2022
Identificador: 
INCIBE-2022-0786
Importancia: 
3 - Media
Recursos afectados: 
  • Versiones Drupal core 9.2 anteriores a 9.2.21;
  • versiones Drupal core 9.3 anteriores a 9.3.16;
  • versiones Drupal core 9.4 anteriores a  Drupal 9.4.0-rc2;
  • todas las versiones de Drupal 9 anteriores a 9.2.x, junto con Drupal 8, están al final de su vida útil (EOL) y no reciben cobertura de seguridad.

Drupal 7 no está afectado.

Descripción: 

Dos vulnerabilidades, de severidad media, en la librería Guzzle, podrían afectar a algunos proyectos contribuidos o al código personalizado de las webs que usan Drupal.

Solución: 

Actualizar a Drupal core 9.2.21, 9.3.16 o 9.4.0-rc2, según la versión afectada.

Detalle: 

Drupal utiliza la librería externa Guzzle para gestionar las solicitudes y respuestas HTTP a los servicios externos. Esta librería presenta dos vulnerabilidades que han sido corregidas:

  • fallo en la eliminación de la cabecera 'cookie' en el cambio de host o en el downgrade HTTP. Se ha asignado el identificador CVE-2022-31042 para esta vulnerabilidad;
  • fallo de quitar la cabecera de 'autorización' en el downgrade HTTP. Se ha asignado el identificador CVE-2022-31043 para esta vulnerabilidad.

Encuesta valoración