Inicio / Content / Boletín de INCIBE-CERT del 07-04-2022

Boletín de INCIBE-CERT del 07-04-2022

[Actualización 03/05/2022] Múltiples vulnerabilidades en productos CODESYS

Fecha de publicación: 
07/04/2022
Importancia: 
4 - Alta
Recursos afectados: 
  • Todas las variantes de los siguientes productos CODESYS V3 que contengan los componentes CmpWebServer, CmpTraceMgr, CmpUserMgr, CmpCAAFile, SysFile, CmpChannelMgr, SysDrv3S.sys o CmpChannelMgrEmbedded en todas las versiones anteriores a 3.5.18.0, independientemente del tipo de CPU o del sistema operativo:
    • CODESYS Control RTE (SL),
    • CODESYS Control RTE (para Beckhoff CX) SL,
    • CODESYS Control Win (SL),
    • CODESYS HMI (SL),
    • CODESYS Development System V3 (el tiempo de ejecución de la simulación se ve afectado),
    • CODESYS Control Runtime System Toolkit,
    • CODESYS Embedded Target Visu Toolkit,
    • CODESYS Remote Target Visu Toolkit,
    • CODESYS Gateway,
    • CODESYS Edge Gateway para Windows,
    • CODESYS OPC DA Server SL,
    • CODESYS PLCHandler.
  • Los siguientes productos basados en CODESYS Control V3 Runtime System Toolkit están afectados en todas las versiones anteriores a 4.5.0.0:
    • CODESYS Control para BeagleBone SL,
    • CODESYS Control para Beckhoff CX9020 SL,
    • CODESYS Control para emPC-A/iMX6 SL,
    • CODESYS Control para IOT2000 SL,
    • CODESYS Control para Linux SL,
    • CODESYS Control para PFC100 SL,
    • CODESYS Control para PFC200 SL,
    • CODESYS Control para PLCnext SL,
    • CODESYS Control para Raspberry Pi SL,
    • CODESYS Control para WAGO Touch Panels 600 SL,
    • CODESYS Edge Gateway para Linux.
Descripción: 

Varios investigadores han reportado 7 vulnerabilidades en productos CODESYS, 6 de severidad alta y 1 media, cuya explotación podría permitir a un atacante leer o modificar archivos de configuración, asignar permisos incorrectos a recursos críticos, interrumpir comunicaciones en progreso, gestionar incorrectamente los usuarios, sobrescribir localmente la memoria o desbordar el búfer de lectura.

Solución: 

Actualizar los productos afectados a las versiones correctoras incluidas en el apartado Available software updates de cada aviso de CODESYS.

Detalle: 

Las vulnerabilidades altas se describen a continuación:

  • El programa de control podría utilizar esta vulnerabilidad para leer y modificar el o los archivos de configuración de los productos afectados a través de las bibliotecas de código IEC para el acceso a los archivos. Se ha asignado el identificador CVE-2022-22515 para esta vulnerabilidad.
  • El controlador SysDrv3S podría permitir mapear direcciones físicas arbitrarias en el propio espacio de proceso y acceder a ellas. Se ha asignado el identificador CVE-2022-22516 para esta vulnerabilidad.
  • Los servidores de comunicación del protocolo CODESYS generan identificadores de canal débiles, que podrían ser adivinados por los atacantes para interrumpir la comunicación en curso. Se ha asignado el identificador CVE-2022-22517 para esta vulnerabilidad.
  • Los servidores de comunicación del protocolo CODESYS podrían permitir que solicitudes manipuladas y autentificadas hagan referencia a punteros nulos o a punteros no confiables. Se han asignado los identificadores CVE-2022-22513 y CVE-2022-22514 para estas vulnerabilidades.
  • Solicitudes especialmente diseñadas de HTTP/HTTPS podrían provocar una sobrelectura del búfer interno, lo que podría bloquear la tarea del servidor web del sistema de tiempo de ejecución de CODESYS Control. Se ha asignado el identificador CVE-2022-22519 para esta vulnerabilidad.

La vulnerabilidad de severidad media tiene asignado el identificador CVE-2022-22518.

Encuesta valoración

Múltiples vulnerabilidades en MELSEC C Controller Module de Mitsubishi Electric

Fecha de publicación: 
07/04/2022
Importancia: 
5 - Crítica
Recursos afectados: 

MELSEC C Controller Module Q12DCCPU-V, versiones con los 5 primeros dígitos del número de serie iguales a 24031 o valores anteriores.

Descripción: 

Mitsubishi Electric ha publicado una vulnerabilidad crítica que podría permitir a un atacante, remoto, la denegación del servicio o la ejecución de código malicioso.

Solución: 

Actualizar MELSEC C Controller Module Q12DCCPU-V a versiones con los 5 primeros dígitos del número de serie iguales a 24032 o valores posteriores.

Detalle: 

Un desbordamiento de búfer basado en memoria dinámica (heap), en la función de cliente DHCP, podría permitir a un atacante, remoto, la denegación del servicio o la ejecución de código malicioso mediante el envío de paquetes especialmente diseñados. Se ha asignado el identificador CVE-2021-29998 para esta vulnerabilidad.

Encuesta valoración

Dirty Pipe: vulnerabilidad de escalada de privilegios en el Kernel de Linux en Sistemas de Control Industrial

Fecha de publicación: 
07/04/2022
Importancia: 
4 - Alta
Recursos afectados: 
  • WAGO PFC100/PFC200 y WAGO Compact Controller CC100:
    • 750-81xx/xxx-xxx, versiones 03.07.14(19) <= 03.07.18(19);
    • 750-81xx/xxx-xxx, versiones 03.08.07(20) <= 03.08.08(20);
    • 750-8217/xxx-xxx, versiones 03.07.14(19) <= 03.07.18(19);
    • 750-8217/xxx-xxx, versiones 03.08.07(20) <= 03.08.08(20);
    • 750-82xx/xxx-xxx, versiones 03.07.14(19) <= 03.07.18(19);
    • 750-82xx/xxx-xxx, versiones 03.08.07(20) <= 03.08.08(20).
    • 751-9301, versiones 03.07.14(19) <= 03.08.08(20);
  • WAGO Touch Panel 600 y WAGO Edge Controller:
    • 752-8303/8000-002, versiones 03.07.14(19) <= 03.07.18(19);
    • 762-4xxx, versiones 03.07.14(19) <= 03.07.18(19);
    • 762-5xxx, versiones 03.07.14(19) <= 03.07.18(19);
    • 762-6xxx, versiones 03.07.14(19) <= 03.07.18(19).
Descripción: 

El investigador de seguridad, Max Kellermann (CM4all) ha notificado una vulnerabilidad, denominada Dirty Pipe, que podría permitir a un usuario sin privilegios inyectar y sobrescribir datos en archivos de solo lectura, incluidos los procesos SUID que se ejecutan como root. La vulnerabilidad se encuentra en el Kernel de Linux utilizado por algunos productos de Sistemas de Control Industrial. El CERT@VDE ha coordinado la publicación de los productos afectados del fabricante WAGO.

Solución: 

Para los productos de WAGO, actualizar a la última versión de firmware.

  • WAGO PFC100/PFC200 y WAGO Compact Controller CC100:
    • 750-81xx/xxx-xxx, versión 03.09.04(21) o superior;
    • 750-8217/xxx-xxx, versión 03.09.05(21) o superior;
    • 750-82xx/xxx-xxx, versión 03.09.04(21) o superior;
    • 751-9301, versión 03.09.04(21) o superior.
  • WAGO Touch Panel 600 y WAGO Edge Controller:
    • 762-4xxx, versión 03.07.19(19) o superior;
    • 762-5xxx, versión 03.07.19(19) o superior;
    • 762-6xxx, versión 03.07.19(19) o superior;
    • 752-8303/8000-002, versión 03.07.19(19) o superior.
Detalle: 

Se ha detectado una vulnerabilidad en la forma en que el miembro flags de la nueva estructura de búfer de tuberías (pipes) carece de la inicialización adecuada en las funciones copy_page_to_iter_pipe y push_pipe en el Kernel de Linux y, por tanto, podría contener valores obsoletos. Un usuario local, sin privilegios, podría utilizar este fallo para escribir en las páginas de la caché de páginas respaldadas por archivos de solo lectura y, de este modo, escalar sus privilegios en el sistema. Se demostró al crear nuevas pipe buffers con la flag PIPE_BUF_FLAG_CAN_MERGE establecida incorrectamente, debido a la falta de una inicialización adecuada. Se ha asignado el identificador CVE-2022-0847 para esta vulnerabilidad.

Encuesta valoración