Inicio / Content / Boletín de INCIBE-CERT del 06-03-2020

Boletín de INCIBE-CERT del 06-03-2020

Múltiples vulnerabilidades en productos TC Router y TC Cloud Client de Phoenix Contact

Fecha de publicación: 
06/03/2020
Importancia: 
5 - Crítica
Recursos afectados: 
  • TC ROUTER:
    • TC ROUTER 3002T-4G, versiones anteriores o iguales a la 2.05.3;
    • TC ROUTER 3002T-4G, versiones anteriores o iguales a la 2.05.3;
    • TC ROUTER 2002T-3G, versiones anteriores o iguales a la 2.05.3;
    • TC ROUTER 2002T-3G, versiones anteriores o iguales a la 2.05.3;
    • TC ROUTER 3002T-4G VZW, versiones anteriores o iguales a la 2.05.3;
    • TC ROUTER 3002T-4G ATT, versiones anteriores o iguales a la 2.05.3.
  • TC CLOUD CLIENT:
    • TC CLOUD CLIENT 1002-4G, versiones anteriores o iguales a la 2.03.17;
    • TC CLOUD CLIENT 1002-4G VZW, versiones anteriores o iguales a la 2.03.17;
    • TC CLOUD CLIENT 1002-4G ATT, versiones anteriores o iguales a la 2.03.17;
    • TC CLOUD CLIENT 1002-TXTX, versiones anteriores o iguales a la 1.03.17.
Descripción: 

Thomas Weber, de SEC Consult Vulnerability Lab, ha identificado múltiples vulnerabilidades de tipo inyección de comandos, falta de validación de nombres de archivos de entrada y uso de certificado fijo en el hardware, que podrían permitir a un atacante ejecutar código remoto, escribir archivos arbitrarios, inyectar comandos y divulgar información sensible.

Solución: 

Actualizar a las siguientes versiones:

  • TC ROUTER:
  • TC CLOUD CLIENT:
    • TC CLOUD CLIENT 1002-4G, 2.03.18,
    • TC CLOUD CLIENT 1002-4G VZW 2.03.18,
    • TC CLOUD CLIENT 1002-4G ATT 2.03.18,
    • TC CLOUD CLIENT 1002-TXTX 1.03.18.
Detalle: 
  • En BusyBox 1.27.2, la función de autocompletar en la shell, usado para conseguir una lista de nombres de archivo en un directorio, no controla los nombres de archivos, por lo que permite la ejecución de cualquier secuencia escapada en el terminal. Se ha asignado el identificador CVE-2017-16544 para esta vulnerabilidad.
  • El envío de una petición POST a un programa CGI, el cual está disponible en la interfaz web, podría permitir a un atacante la inyección de comandos. Se ha asignado el identificador CVE-2020-9436 para esta vulnerabilidad.
  • El dispositivo contiene certificados fijos en el firmware usados para ejecutar el servicio web, lo que podría permitir la suplantación de identidad, ataques man-in-the-middle o descifrado pasivo de ataques, si el certificado genérico no es reemplazado por un certificado específico durante la instalación. Se ha asignado el identificador CVE-2020-9435 para esta vulnerabilidad.

Encuesta valoración