Inicio / Content / Boletín de INCIBE-CERT del 04-05-2022

Boletín de INCIBE-CERT del 04-05-2022

Ejecución remota de código en switches de Aruba

Fecha de publicación: 
04/05/2022
Importancia: 
5 - Crítica
Recursos afectados: 
  • Aruba Switch Models:
    • Aruba 5400R Series,
    • Aruba 3810 Series,
    • Aruba 2920 Series,
    • Aruba 2930F Series,
    • Aruba 2930M Series,
    • Aruba 2530 Series,
    • Aruba 2540 Series.
  • Versiones de Software:
    • ArubaOS-Switch 15.xx.xxxx, todas las versiones;
    • ArubaOS-Switch 16.01.xxxx, todas las versiones;
    • ArubaOS-Switch 16.02.xxxx, versión K.16.02.0033 y anteriores;
    • ArubaOS-Switch 16.03.xxxx, todas las versiones;
    • ArubaOS-Switch 16.04.xxxx, todas las versiones;
    • ArubaOS-Switch 16.05.xxxx, todas las versiones;
    • ArubaOS-Switch 16.06.xxxx, todas las versiones;
    • ArubaOS-Switch 16.07.xxxx, todas las versiones;
    • ArubaOS-Switch 16.08.xxxx, versión KB/WB/WC/YA/YB/YC.16.08.0024 y anteriores;
    • ArubaOS-Switch 16.09.xxxx, versión KB/WB/WC/YA/YB/YC.16.09.0019 y anteriores;
    • ArubaOS-Switch 16.10.xxxx, versión KB/WB/WC/YA/YB/YC.16.10.0019 y anteriores;
    • ArubaOS-Switch 16.11.xxxx, versión KB/WB/WC/YA/YB/YC.16.11.0003 y anteriores.
Descripción: 

El equipo de investigación de Armis ha descubierto múltiples vulnerabilidades de desbordamiento de búfer basado en memoria dinámica (heap) en varios dispositivos de Aruba que podría permitir a un atacante remoto la ejecución de código arbitrario en el dispositivo afectado.

Solución: 
  • Actualizar:
    • ArubaOS-Switch 16.02.xxxx, a la versión K.16.02.0034 y superior;
    • ArubaOS-Switch 16.08.xxxx, a la versión KB/WB/WC/YA/YB/YC.16.08.0025 o superior;
    • ArubaOS-Switch 16.09.xxxx, a la versión KB/WB/WC/YA/YB/YC.16.09.0020 o superior;
    • ArubaOS-Switch 16.10.xxxx, a la versión KB/WB/WC/YA/YB/YC.16.10.0020 o superior;
    • ArubaOS-Switch 16.11.xxxx, a la versión KB/WB/WC/YA/YB/YC.16.11.0004 o superior;

El resto de productos se actualizarán próximamente.

Detalle: 

Múltiples vulnerabilidades de desbordamiento de búfer basado en memoria dinámica (heap), en el firmware de ArubaOS-Switch y en la biblioteca criptográfica Mocana, en el firmware de ArubaOS-Switch, podrían permitir a un atacante remoto la ejecución de código arbitrario en el dispositivo afectado. La explotación de estas vulnerabilidades requiere la interacción de un switch afectado con una fuente de mensajes de desafío de acceso RADIUS controlada por un atacante. Debido a esto, la explotación de estas vulnerabilidades probablemente ocurriría como parte de una cadena de ataque que se basa en la explotación previa de la infraestructura controlada por el cliente. Se han asignado los identificadores CVE-2022-23676 y CVE-2022-23677 para estas vulnerabilidades.

Encuesta valoración