Inicio / Alerta Temprana / Vulnerabilidades / CVE-2022-40654

Vulnerabilidad en el análisis de los archivos X_T en Ansys SpaceClaim (CVE-2022-40654)

Tipo: 
Escritura fuera de límites
Gravedad: 
Sin asignar
Fecha publicación : 
15/09/2022
Última modificación: 
19/09/2022
Descripción
Esta vulnerabilidad permite a atacantes remotos ejecutar código arbitrario en las instalaciones afectadas de Ansys SpaceClaim versión 2022 R1. Es requerida una interacción del usuario para explotar esta vulnerabilidad, ya que el objetivo debe visitar una página maliciosa o abrir un archivo malicioso. El fallo específico se presenta en el análisis de los archivos X_T. El problema es debido a una falta de comprobación apropiada de los datos suministrados por el usuario, lo que puede resultar en una escritura más allá del final de una estructura de datos asignada. Un atacante puede aprovechar esta vulnerabilidad para ejecutar código en el contexto del proceso actual. Era ZDI-CAN-18351
Impacto
Vector de acceso: No disponible
Complejidad de Acceso: No disponible
Autenticación: No disponible
Tipo de impacto: No disponible
Productos y versiones vulnerables
  • cpe:2.3:a:ansys:spaceclaim:2022:r1:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos