Inicio / Alerta Temprana / Vulnerabilidades / CVE-2022-30067

Vulnerabilidad en un archivo XCF en GIMP (CVE-2022-30067)

Tipo: 
Copia de búfer sin comprobación del tamaño de entrada (Desbordamiento de búfer clásico)
Gravedad: 
Media
Fecha publicación : 
17/05/2022
Última modificación: 
25/05/2022
Descripción
GIMP versiones 2.10.30 y 2.99.10, son vulnerables a un Desbordamiento del Búfer. Mediante un archivo XCF diseñado, el programa asignará una gran cantidad de memoria, resultando en una memoria insuficiente o en un bloqueo del programa
Impacto
Vector de acceso: A través de red
Complejidad de Acceso: Media
Autenticación: No requerida para explotarla
Tipo de impacto: No hay impacto en la integridad del sistema + No hay impacto en la confidencialidad del sistema + Afecta parcialmente a la disponibilidad del sistema
Productos y versiones vulnerables
  • cpe:2.3:a:gimp:gimp:2.99.10:*:*:*:*:*:*:*
  • cpe:2.3:a:gimp:gimp:2.10.30:*:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos