Inicio / Alerta Temprana / Vulnerabilidades / CVE-2022-21190

Vulnerabilidad en el paquete convict (CVE-2022-21190)

Tipo: 
No disponible / Otro tipo
Gravedad: 
Sin asignar
Fecha publicación : 
13/05/2022
Última modificación: 
13/05/2022
Descripción
Esto afecta al paquete convict versiones anteriores a 6.2.3. Esto es una omisión de [CVE-2022-22143](https://security.snyk.io/vuln/SNYK-JS-CONVICT-2340604). La [fix](https://github.com/mozilla/node-convict/commit/3b86be087d8f14681a9c889d45da7fe3ad9cd880) introducida, esta basada en el método startsWith y no impide la vulnerabilidad: antes de dividir la ruta, comprueba si comienza con __proto__ o this.constructor.prototype. Para impider esta comprobación es posible anteponer a las rutas peligrosas cualquier valor de cadena seguido de un punto, como por ejemplo foo.__proto__ o foo.this.constructor.prototype
Impacto
Vector de acceso: No disponible
Complejidad de Acceso: No disponible
Autenticación: No disponible
Tipo de impacto: No disponible
Referencias a soluciones, herramientas e información
  • N/A (Origen: CONFIRM)
  • N/A (Origen: CONFIRM)
  • N/A (Origen: CONFIRM)
  • N/A (Origen: CONFIRM)
  • N/A (Origen: CONFIRM)
Explicación de los campos