Inicio / Alerta Temprana / Vulnerabilidades / CVE-2021-23378

Vulnerabilidad en las funciones say y exec child_process en el paquete picotts (CVE-2021-23378)

Tipo: 
Neutralización incorrecta de elementos especiales usados en un comando (Inyección de comando)
Gravedad: 
Alta
Fecha publicación : 
18/04/2021
Última modificación: 
22/04/2021
Descripción
Esto afecta a todas las versiones de los paquetes picotts. Si es proporcionada una entrada de usuario controlada por un atacante para la función say, es posible para un atacante ejecutar comandos arbitrarios. Esto es debido al uso de la función exec child_process sin un saneamiento de la entrada
Impacto
Vector de acceso: A través de red
Complejidad de Acceso: Baja
Autenticación: No requerida para explotarla
Tipo de impacto: Afecta parcialmente a la integridad del sistema + Afecta parcialmente a la confidencialidad del sistema + Afecta parcialmente a la disponibilidad del sistema
Productos y versiones vulnerables
  • cpe:2.3:a:picotts_project:picotts:*:*:*:*:*:node.js:*:*
Para consultar la lista completa de productos y versiones ver esta página
Explicación de los campos