Inicio / Alerta Temprana / Vulnerabilidades / CVE-2021-0432

Vulnerabilidad en el archivo StatsPullerManager.cpp en las funciones ClearPullerCacheIfNeeded y ForceClearPullerCache de Android (CVE-2021-0432)

Tipo: 
Ejecución concurrente utilizando recursos compartidos con una incorrecta sincronización (Condición de carrera)
Gravedad: 
Media
Fecha publicación : 
13/04/2021
Última modificación: 
16/04/2021
Descripción
En las funciones ClearPullerCacheIfNeeded y ForceClearPullerCache del archivo StatsPullerManager.cpp, se presenta un posible uso de la memoria previamente liberada debido a una condición de carrera. Esto podría conllevar a una escalada de privilegios local sin ser necesarios privilegios de ejecución adicionales. No es requerida una interacción del usuario para su explotación. Producto: Android, Versiones: Android-11, ID de Android: A-173552790
Impacto
Vector de acceso: Local
Complejidad de Acceso: Media
Autenticación: No requerida para explotarla
Tipo de impacto: Afecta parcialmente a la integridad del sistema + Afecta parcialmente a la confidencialidad del sistema + Afecta parcialmente a la disponibilidad del sistema
Productos y versiones vulnerables
  • cpe:2.3:o:google:android:11.0:*:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos