Inicio / Alerta Temprana / Vulnerabilidades / CVE-2020-27788

Vulnerabilidad en el archivo p_lx_elf.cpp en la función PackLinuxElf64::canPack() en UPX (CVE-2020-27788)

Tipo: 
Lectura fuera de límites
Gravedad: 
Sin asignar
Fecha publicación : 
18/08/2022
Última modificación: 
22/08/2022
Descripción
Se ha detectado una vulnerabilidad de acceso de lectura fuera de límites en UPX en la función PackLinuxElf64::canPack() del archivo p_lx_elf.cpp. Un atacante con un archivo de entrada diseñado podría desencadenar este problema que podría causar un bloqueo conllevando a una denegación de servicio.
Impacto
Vector de acceso: No disponible
Complejidad de Acceso: No disponible
Autenticación: No disponible
Tipo de impacto: No disponible
Productos y versiones vulnerables
  • cpe:2.3:a:upx_project:upx:*:*:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos