Inicio / Alerta Temprana / Vulnerabilidades / CVE-2020-27216

Vulnerabilidad en el directorio temporal del sistema en sistemas similares a Unix en Eclipse Jetty (CVE-2020-27216)

Tipo: 
No disponible / Otro tipo
Gravedad: 
Media
Fecha publicación : 
23/10/2020
Última modificación: 
25/11/2020
Descripción
En Eclipse Jetty versiones 1.0 hasta 9.4.32.v20200930, versiones 10.0.0.alpha1 hasta 10.0.0.beta2 y versiones 11.0.0.alpha1 hasta 11.0.0.beta2O, en sistemas similares a Unix, el directorio temporal del sistema es compartido entre todos los usuarios en ese sistema. Un usuario colocado puede observar el proceso de creación de un subdirectorio temporal en el directorio temporal compartido y correr para completar la creación del subdirectorio temporal. Si el atacante gana la carrera, tendrá permiso de lectura y escritura en el subdirectorio usado para descomprimir las aplicaciones web, incluyendo sus archivos jar WEB-INF/lib y archivos JSP. Si alguna vez es ejecutado algún código fuera de este directorio temporal, esto puede conllevar a una vulnerabilidad de escalada de privilegios local
Impacto
Vector de acceso: Local
Complejidad de Acceso: Baja
Autenticación: No requerida para explotarla
Tipo de impacto: Afecta parcialmente a la integridad del sistema + Afecta parcialmente a la confidencialidad del sistema + Afecta parcialmente a la disponibilidad del sistema
Productos y versiones vulnerables
  • cpe:2.3:a:eclipse:jetty:11.0.0:beta2:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:11.0.0:beta1:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:11.0.0:alpha1:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:10.0.0:beta2:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:10.0.0:beta1:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:10.0.0:beta0:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:10.0.0:alpha1:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:10.0.0:alpha0:*:*:*:*:*:*
  • cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos