Inicio / Alerta Temprana / Vulnerabilidades / CVE-2019-12929

Vulnerabilidad en el comando QMP guest_exec en QEMU (CVE-2019-12929)

Tipo: 
Neutralización incorrecta de elementos especiales usados en un comando de sistema operativo (Inyección de comando de sistema operativo)
Gravedad: 
Alta
Fecha publicación : 
24/06/2019
Última modificación: 
02/07/2019
Descripción
**EN DISPUTA** El comando QMP guest_exec en QEMU versión 4.0.0 y anteriores es propenso a la inyección de comandos del sistema operativo, lo que permite al atacante remoto lograr la ejecución de código, una denegación de servicio, o la divulgación de información mediante el envío de un comando QMP manipulado al servidor de escucha. Nota: Está siendo discutida por no ser un problema ya que la interfaz -qmp de QEMU está destinada a ser utilizada por usuarios de confianza. Si uno puede acceder a esta interfaz a través de un socket TCP abierto a Internet, entonces es un problema de configuración inseguro.
Impacto
Vector de acceso: A través de red
Complejidad de Acceso: Baja
Autenticación: No requerida para explotarla
Tipo de impacto: Compromiso total de la integridad del sistema + Compromiso total de la confidencialidad del sistema + Compromiso total de la disponibilidad del sistema
Productos y versiones vulnerables
  • cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:*
Para consultar la lista completa de productos y versiones ver esta página
Referencias a soluciones, herramientas e información
Explicación de los campos