Inicio / Alerta Temprana / Vulnerabilidades / CVE-2018-17196

Vulnerabilidad en Kafka (CVE-2018-17196)

Tipo: 
Validación incorrecta de entrada
Gravedad: 
Media
Fecha publicación : 
11/07/2019
Última modificación: 
18/07/2019
Descripción
Kafka versiones entre 0.11.0.0 y 2.1.0 de Apache, es posible diseñar manualmente una petición Produce que omita la comprobación ACL de transaction/idempotent. Solo los clientes autenticados con permiso de escritura en los temas respectivos pueden explotar esta vulnerabilidad. Los usuarios deben actualizar a la versión 2.1.1 o posterior, donde esta vulnerabilidad ha sido solucionada.
Impacto
Vector de acceso: A través de red
Complejidad de Acceso: Baja
Autenticación: Requiere una única instancia para explotarla
Tipo de impacto: Afecta parcialmente a la integridad del sistema + Afecta parcialmente a la confidencialidad del sistema + Afecta parcialmente a la disponibilidad del sistema
Productos y versiones vulnerables
  • Apache Kafka 2.1.0
  • Apache Kafka 2.0.0
  • Apache Kafka 1.1.1
  • Apache Kafka 1.1.0
  • Apache Kafka 1.0.2
  • Apache Kafka 1.0.1
  • Apache Kafka 1.0.0
  • Apache Kafka 0.11.0.3
  • Apache Kafka 0.11.0.2
  • Apache Kafka 0.11.0.1
  • Apache Kafka 0.11.0.0
Referencias a soluciones, herramientas e información
Explicación de los campos