Inicio / Alerta Temprana / Vulnerabilidades / Vulnerabilidades
Suscribirse a INCIBE-CERT - Vulnerabilities RSS

Vulnerabilidades

CVE-2017-20175

Gravedad: 
Sin asignar
Fecha publicación : 
05/02/2023
Última modificación: 
05/02/2023
Descripción:  
*** Pendiente de traducción *** A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The name of the patch is 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.

CVE-2023-22849

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Sling App CMS version 1.1.4 and prior may allow an authenticated remote attacker to perform a reflected cross-site scripting (XSS) attack in multiple features. Upgrade to Apache Sling App CMS >= 1.1.6

CVE-2022-45786

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** There are issues with the AGE drivers for Golang and Python that enable SQL injections to occur. This impacts AGE for PostgreSQL 11 & AGE for PostgreSQL 12, all versions up-to-and-including 1.1.0, when using those drivers. The fix is to update to the latest Golang and Python drivers in addition to the latest version of AGE that is used for PostgreSQL 11 or PostgreSQL 12. The update of AGE will add a new function to enable parameterization of the cypher() function, which, in conjunction with the driver updates, will resolve this issue. Background (for those who want more information): After thoroughly researching this issue, we found that due to the nature of the cypher() function, it was not easy to parameterize the values passed into it. This enabled SQL injections, if the developer of the driver wasn't careful. The developer of the Golang and Pyton drivers didn't fully utilize parameterization, likely because of this, thus enabling SQL injections. The obvious fix to this issue is to use parameterization in the drivers for all PG SQL queries. However, parameterizing all PG queries is complicated by the fact that the cypher() function call itself cannot be parameterized directly, as it isn't a real function. At least, not the parameters that would take the graph name and cypher query. The reason the cypher() function cannot have those values parameterized is because the function is a placeholder and never actually runs. The cypher() function node, created by PG in the query tree, is transformed and replaced with a query tree for the actual cypher query during the analyze phase. The problem is that parameters - that would be passed in and that the cypher() function transform needs to be resolved - are only resolved in the execution phase, which is much later. Since the transform of the cypher() function needs to know the graph name and cypher query prior to execution, they can't be passed as parameters. The fix that we are testing right now, and are proposing to use, is to create a function that will be called prior to the execution of the cypher() function transform. This new function will allow values to be passed as parameters for the graph name and cypher query. As this command will be executed prior to the cypher() function transform, its values will be resolved. These values can then be cached for the immediately following cypher() function transform to use. As added features, the cached values will store the calling session's pid, for validation. And, the cypher() function transform will clear this cached information after function invocation, regardless of whether it was used. This method will allow the parameterizing of the cypher() function indirectly and provide a way to lock out SQL injection attacks.

CVE-2023-25193

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** hb-ot-layout-gsubgpos.hh in HarfBuzz through 6.0.0 allows attackers to trigger O(n^2) growth via consecutive marks during the process of looking back for base glyphs when attaching marks.

CVE-2023-0678

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** Improper Authorization in GitHub repository phpipam/phpipam prior to v1.5.1.

CVE-2023-0677

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** Cross-site Scripting (XSS) - Reflected in GitHub repository phpipam/phpipam prior to v1.5.1.

CVE-2023-0676

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** Cross-site Scripting (XSS) - Reflected in GitHub repository phpipam/phpipam prior to 1.5.1.

CVE-2023-0675

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** A vulnerability, which was classified as critical, was found in Calendar Event Management System 2.3.0. This affects an unknown part. The manipulation of the argument start/end leads to sql injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-220197 was assigned to this vulnerability.

CVE-2023-0674

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** A vulnerability, which was classified as problematic, has been found in XXL-JOB 2.3.1. Affected by this issue is some unknown functionality of the file /user/updatePwd of the component New Password Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-220196.

CVE-2023-0673

Gravedad: 
Sin asignar
Fecha publicación : 
04/02/2023
Última modificación: 
04/02/2023
Descripción:  
*** Pendiente de traducción *** A vulnerability classified as critical was found in SourceCodester Online Eyewear Shop 1.0. Affected by this vulnerability is an unknown functionality of the file oews/products/view_product.php. The manipulation of the argument id leads to sql injection. The attack can be launched remotely. The associated identifier of this vulnerability is VDB-220195.

Páginas