Inicio / Alerta Temprana / Avisos Seguridad / Vulnerabilidades de desbordamiento de búfer en Grandstream GSD3710

Vulnerabilidades de desbordamiento de búfer en Grandstream GSD3710

Fecha de publicación: 
20/09/2022
Identificador: 
INCIBE-2022-0925
Importancia: 
5 - Crítica
Recursos afectados: 

Grandstream GSD3710, versión 1.0.11.13.

Descripción: 

INCIBE ha coordinado la publicación de 2 vulnerabilidades en Grandstream GSD3710, con el código interno INCIBE-2022-0925, que han sido descubiertas por José Luis Verdeguer Navarro.

A estas vulnerabilidades se les han asignado los códigos:

  • CVE-2022-2070. Se ha calculado una puntuación base CVSS v3.1 de 9,8, siendo el cálculo del CVSS el siguiente: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
  • CVE-2022-2025. Se ha calculado una puntuación base CVSS v3.1 de 9,8, siendo el cálculo del CVSS el siguiente: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
Solución: 

Las vulnerabilidades han sido resueltas por Grandstream en la versión 1.0.11.23.

Detalle: 
  • CVE-2022-2070: en la versión 1.0.11.13 de Grandstream GSD3710, es posible desbordar la pila ya que no comprueba la longitud del parámetro antes de utilizar la instrucción sscanf. Debido a esto, un atacante podría crear un socket y conectarse con un IP:port remoto abriendo una shell y obteniendo acceso completo al sistema. El exploit afecta a los demonios dbmng y logsrv que se ejecutan en los puertos 8000 y 8001 por defecto.
  • CVE-2022-2025: un atacante con conocimiento del user/pass de Grandstream GSD3710 en su versión 1.0.11.13, podría desbordar la pila ya que no comprueba la longitud del parámetro antes de utilizar la instrucción strcopy. La explotación de esta vulnerabilidad podría llevar a un atacante a ejecutar una shell con acceso completo.

Ambas vulnerabilidades son del tipo CWE-121: desbordamiento de búfer basado en pila (stack).

Si tiene más información sobre este aviso, póngase en contacto con INCIBE, como se indica en la sección de asignación y publicación de CVE.

Encuesta valoración