Inicio / Alerta Temprana / Avisos Seguridad / Vulnerabilidad en TLS de Mbed

Vulnerabilidad en TLS de Mbed

Fecha de publicación: 
04/12/2018
Importancia: 
4 - Alta
Recursos afectados: 
  • Todas las versiones de Mbed TLS.
Descripción: 

La vulnerabilidad de criticidad alta podría permitir a un atacante local sin privilegios recuperar el texto plano del descifrado RSA que se utiliza en las suites de cifrado RSA-sin-(EC)DH(E).

Solución: 
  • Actualizar a una de las versiones más recientes de Mbed TLS, incluyendo 2.14.1, 2.7.8 o 2.1.17 o posteriores.
  • Las versiones actualizadas de Mbed TLS siguen siendo vulnerables a una de las fugas si el tamaño de la clave RSA no es múltiplo del tamaño de palabra de la máquina, por lo que se recomienda que se utilicen tamaños de clave que sean múltiplos de 64 bits.
Detalle: 
  • La vulnerabilidad podría permitir a un atacante ejecutar código y recuperar el texto sin formato a través de un Bleichenbacher oracle. En particular, afecta a las conexiones (D)TLS que utilizan descifrado RSA, donde el atacante podría descifrar la conexión mediante un ataque de recuperación de texto en el servidor o interceptar la conexión mediante un ataque man-in-the-middle sobre el contenido. Se ha reservado el CVE-2018-19608 para esta vulnerabilidad.

Encuesta valoración