Inicio / Alerta Temprana / Avisos Seguridad / Vulnerabilidad en el core de Drupal

Vulnerabilidad en el core de Drupal

Fecha de publicación: 
19/11/2020
Importancia: 
5 - Crítica
Recursos afectados: 

Versiones anteriores a:

  • 9.0.8;
  • 8.9.9;
  • 8.8.11;
  • 7.74.
Descripción: 
Se ha publicado una vulnerabilidad, de severidad crítica, de tipo ejecución remota de código (RCE), que afecta al core de Drupal.
Solución: 

Actualizar a las versiones 9.0.8, 8.9.9, 8.8.11 o 7.74.

Las versiones de Drupal 8, anteriores a 8.8.x, están al final de su vida útil y ya no reciben cobertura de seguridad.

Además, es recomendable auditar todos los archivos cargados anteriormente para verificar si hay extensiones maliciosas. Concretamente, archivos que incluyan más de una extensión, como nombre de archivo.php.txt o nombre de archivo.html.gif, sin un guión bajo (_) en la extensión. Las siguientes extensiones de archivo deben considerarse peligrosas, incluso cuando van seguidas de una o más extensiones adicionales:

  • phar,
  • php,
  • pl,
  • py,
  • cgi,
  • asp,
  • js,
  • html,
  • htm,
  • phtml.

Este listado no es exhaustivo, por lo que es conveniente evaluar la seguridad de otras extensiones no mencionadas.

Detalle: 

El saneado inadecuado de ciertos nombres de archivo en los archivos cargados, podría provocar que los archivos se interpreten como la extensión incorrecta y sirvan como el tipo MIME incorrecto o se ejecuten como PHP para configuraciones de host concretas. Se ha asignado el identificador CVE-2020-13671 para esta vulnerabilidad.

Encuesta valoración