Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en Xen

Múltiples vulnerabilidades en Xen

Fecha de publicación: 
08/07/2020
Importancia: 
4 - Alta
Recursos afectados: 

Todas las versiones de Xen son vulnerables.

Descripción: 

Diversos investigadores han detectado 5 vulnerabilidades, que en su conjunto afectan a todas las versiones de Xen.

Solución: 

Aplicar los correspondientes parches que aparecen listados en la sección RESOLUTION de cada aviso de Xen, disponibles en las Referencias.

Detalle: 
  • Cuando el administrador configura un invitado (guest) para permitir más de 1023 canales de eventos, ese invitado puede bloquear el host. Cuando Xen se queda sin memoria, la asignación de nuevos canales de eventos provocará el bloqueo del host en lugar de informar con un error. Se ha asignado el identificador CVE-2020-15566 para esta vulnerabilidad.
  • Un invitado de HVM malintencionado podría hacer que el hipervisor se bloquee, lo que generaría una condición de denegación de servicio (DoS) que afectaría a todo el host. Se ha asignado el identificador CVE-2020-15563 para esta vulnerabilidad.
  • Un invitado malintencionado podría retener el acceso de lectura/escritura de DMA a los frames devueltos al pool de Xen y luego reutilizarlos para otro propósito, lo que podría causar bloqueos del host (que conducirían a una denegación de servicio) y una escalada de privilegios. Se ha asignado el identificador CVE-2020-15565 para esta vulnerabilidad.
  • Un administrador invitado, malintencionado, podría causar un bloqueo del hipervisor, lo que resultaría en una condición de denegación de servicio (DoS). Se ha asignado el identificador CVE-2020-15564 para esta vulnerabilidad.
  • Un administrador invitado, e incluso un usuario invitado no privilegiado, podrían causar condiciones de denegación de servicio, corrupción de datos o escalada de privilegios. Se ha asignado el identificador CVE-2020-15567 para esta vulnerabilidad.

Encuesta valoración