Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en VMware

Múltiples vulnerabilidades en VMware

Fecha de publicación: 
13/03/2020
Importancia: 
5 - Crítica
Recursos afectados: 
  • VMware Workstation Pro / Player (Workstation), versiones 15.x;
  • VMware Fusion Pro / Fusion (Fusion), versiones 11.x;
  • VMware Horizon Client para Windows, versiones 5.x y anteriores,
  • VMware Remote Console para Windows (VMRC), versiones 10.x.
Descripción: 

VMware ha publicado tres vulnerabilidades, una de severidad crítica y dos altas, que podrían permitir a un atacante la ejecución de código en el host, la denegación del servicio vmnetdhcp en el host, la escalada local de privilegios o ejecutar comandos como otro usuario.

Solución: 

Actualizar a las siguientes versiones:

  • Workstation 15.5.2,
  • Fusion 11.5.2,
  • Horizon Client para Windows 5.30,
  • VMRC para Windows 11.0.0.
Detalle: 
  • La vulnerabilidad de severidad crítica:
    • VMware Workstation y Fusion contienen una vulnerabilidad de use-after en vmnetdhcp que podría permitir a un atacante la ejecución de código en el host del huésped o crear una condición de denegación de servicio en vmnetdhcp que se ejecuta en la máquina del host. Se ha asignado el identificador CVE-2020-3947 para esta vulnerabilidad.
  • Las vulnerabilidades con severidad alta:
    • Las máquinas virtuales de Linux que se ejecutan en VMware Workstation y Fusion contienen una vulnerabilidad de escalada de privilegios local debido a permisos de archivo inadecuados en Cortado Thinprint. La explotación sólo es posible si VMware Tools está instalado en la máquina virtual (opción predeterminada en Workstation y en Fusion). Un atacante sin acceso de administrador podría aprovechar esta vulnerabilidad para escalar privilegios en la máquina virtual. Se ha asignado el identificador CVE-2020-3948 para esta vulnerabilidad.
    • En VMware Horizon Client, VMRC y Workstation para Windows, la carpeta que contiene los archivos de configuración para el servicio de arbitraje de VMware USB puede ser sobreescrita por cualquier usuario, lo cual podría permitir a un atacante ejecutar comandos como otro usuario. Se ha asignado el identificador CVE-2019-5543 para esta vulnerabilidad.

Encuesta valoración