Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en Squid

Múltiples vulnerabilidades en Squid

Fecha de publicación: 
04/02/2020
Importancia: 
4 - Alta
Recursos afectados: 

Las siguientes versiones de Squid:

  • desde la 2.x hasta la 2.7.STABLE9;
  • desde la 3.x hasta la 3.5.28;
  • desde la 4.x hasta la 4.9.
Descripción: 

Se han detectado tres vulnerabilidades en múltiples versiones del servidor proxy Squid que podrían permitir a un atacante omitir los controles de seguridad de acceso, la denegación del servicio o la divulgación de información.

Solución: 

Actualizar a la versión 4.10.

Detalle: 
  • Debido a una incorrecta validación de la entrada, Squid puede interpretar las solicitudes HTTP, específicamente diseñadas, de manera errónea para acceder a los recursos del servidor prohibidos por los anteriores filtros de seguridad. Además, debido a la incorrecta administración del búfer, un cliente remoto puede causar una condición de desbordamiento de búfer en un Squid que actúa como proxy inverso. Se han reservado los identificadores CVE-2020-8449 y CVE-2020-8450 para esta vulnerabilidad.
  • Debido a la gestión incorrecta de los datos, Squid es vulnerable a la divulgación de información cuando traduce los listados del servidor FTP a respuestas HTTP. Se ha reservado el identificador CVE-2019-12528 para esta vulnerabilidad.
  • Debido a la incorrecta gestión del búfer, el archivo binario ext_lm_group_acl es vulnerable a un ataque de denegación de servicio cuando se procesan las credenciales de autenticación NTLM (NT LAN Manager). Se ha reservado el identificador CVE-2020-8517 para esta vulnerabilidad.

Encuesta valoración