Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en Samba

Múltiples vulnerabilidades en Samba

Fecha de publicación: 
29/07/2022
Identificador: 
INCIBE-2022-0859
Importancia: 
4 - Alta
Recursos afectados: 

Las siguientes versiones de Samba, según la vulnerabilidad concreta:

  • CVE-2022-2031 y CVE-2022-32746: versiones anteriores a 4.16.4;
  • CVE-2022-32742: todas las versiones;
  • CVE-2022-32744: versiones 4.3 y posteriores;
  • CVE-2022-32745: versiones 4.16, 4.15.2, 4.14.10, 4.13.14 y posteriores.
Descripción: 

Varios investigadores han reportado 5 vulnerabilidades, 1 de severidad alta y 4 medias, que podrían permitir a un atacante omitir restricciones de seguridad, interrumpir el proceso del servidor, referenciar memoria después de haberla liberado, divulgación de información o falsificar solicitudes de cambio de contraseña.

Solución: 

Actualizar Samba a las versiones 4.16.4, 4.15.9 o 4.14.14.

Detalle: 

Los tickets recibidos por el servicio kpasswd eran descifrados sin especificar que sólo se debían probar las claves propias de ese servicio. Un atacante podría hacer que el servidor aceptara tickets cifrados con cualquier clave, incluyendo la suya propia. Así, un usuario podría cambiar la contraseña de la cuenta de administrador y obtener el control total del dominio, repercutiendo en la confidencialidad, integridad y disponibilidad del servicio. Se ha asignado el identificador CVE-2022-32744 para esta vulnerabilidad alta.

Para el resto de vulnerabilidades medias se han asignado los identificadores: CVE-2022-2031, CVE-2022-32742, CVE-2022-32745 y CVE-2022-32746.

Encuesta valoración