Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en OpenSMTPD

Múltiples vulnerabilidades en OpenSMTPD

Fecha de publicación: 
26/02/2020
Importancia: 
5 - Crítica
Recursos afectados: 

OpenBSD 6.6.

Descripción: 

Se han publicado múltiples vulnerabilidades, de severidades crítica y baja, en OpenBSD que podrían permitir a un atacante remoto tomar el control de un servidor afectado o la divulgación de información local.

Solución: 

Actualizar a la versión 6.6.4p1.

Detalle: 
  • La vulnerabilidad de severidad baja podría permitir a un atacante local, sin privilegios, leer la primera línea de un archivo arbitrario (por ejemplo, el hash de la contraseña de root en /etc/master.passwd) o el contenido del archivo de otro usuario (si este archivo y /var/spool/smtpd/ están en el mismo sistema de archivos). Esta vulnerabilidad generalmente no es explotable en Linux, ya que /proc/sys/fs/protected_hardlinks es "1" por defecto en la mayoría de las distribuciones, sin embargo si es explotable en Fedora. Se ha asignado el identificador CVE-2020-8793 para esta vulnerabilidad.
  • La vulnerabilidad de severidad crítica consiste en una lectura fuera de límites en smtpd que podría permitir a un atacante remoto inyectar comandos arbitrarios en archivos que luego se ejecutan como root. Por otra parte, la falta de revocación de privilegios en el smtpctl permite ejecutar comandos con el grupo _smtpq. Se ha asignado el identificador CVE-2020-8794 para esta vulnerabilidad.

Encuesta valoración