Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en Moodle

Múltiples vulnerabilidades en Moodle

Fecha de publicación: 
22/09/2020
Importancia: 
4 - Alta
Recursos afectados: 
  • Desde la versión 3.9, hasta la versión 3.9.1;
  • desde la versión 3.8, hasta la versión 3.8.4;
  • desde la versión 3.7, hasta la versión 3.7.7;
  • desde la versión 3.5, hasta la versión 3.5.13;
  • versiones anteriores no compatibles.
Descripción: 

Varios investigadores han reportado 5 vulnerabilidades, 3 con severidad alta y 2 bajas, de tipo XSS almacenado, XSS reflejado, escalada de privilegios, denegación de servicio (DoS) y falta de sanitización de código JavaScript.

Solución: 

Moodle ha publicado diversas actualizaciones, en función de la versión afectada:

  • 3.9.2;
  • 3.8.5;
  • 3.7.8;
  • 3.5.14.
Detalle: 
  • El campo de perfil del usuario moodlenetprofile no valida suficientemente los datos introducidos para evitar el riesgo de sufrir un ataque XSS almacenado. Se ha asignado el identificador CVE-2020-25627 para esta vulnerabilidad.
  • El filtro en el registro de tareas de administración no valida suficientemente los datos introducidos para evitar el riesgo de sufrir un ataque XSS reflejado. Se ha asignado el identificador CVE-2020-25628 para esta vulnerabilidad.
  • El tamaño descomprimido de los archivos zip no se comprobó en relación a la cuota de usuario disponible antes de descomprimirlos, lo que podría generar una condición de denegación de servicio (DoS). Se ha asignado el identificador CVE-2020-25630 para esta vulnerabilidad.

Para el resto de vulnerabilidades con severidad baja, se han asignado los identificadores: CVE-2020-25629 y CVE-2020-25631.

Encuesta valoración