Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en IBM WebSphere Application Server de IBM Cloud

Múltiples vulnerabilidades en IBM WebSphere Application Server de IBM Cloud

Fecha de publicación: 
11/10/2018
Importancia: 
5 - Crítica
Recursos afectados: 

Esta vulnerabilidad afecta a las siguientes versiones de IBM WebSphere Application Server:

  • Liberty
  • Versión 9.0
  • Versión 8.5
Descripción: 

IBM ha publicado un boletín de seguridad describiendo múltiples vulnerabilidades que afectan a IBM WebSphere Application Server perteneciente a IBM Cloud.

Solución: 

Para corregir una instancia de servicio existente, se debe abrir el aviso de la vulnerabilidad específica que aparece listada en la sección Remediation/Fixes del boletín de seguridad y, a continuación, aplicar los pasos descritos en dicha sección. Alternativamente, eliminar la instancia de servicio vulnerable y crear una nueva instancia.

Detalle: 

Las vulnerabilidades descritas son las siguientes:

  • IBM WebSphere Application Server podría permitir a un atacante remoto ejecutar código Java arbitrario a través del conector SOAP (Simple Object Access Protocol) con un objeto serializado de fuentes no confiables. Se ha asignado el identificador CVE-2018-1567 para esta vulnerabilidad.
  •  Apache MyFaces y Oracle Mojarra podrían permitir a un atacante remoto ejecutar código arbitrario en el sistema, causado por una configuración incorrecta de ViewState. Si ViewState está configurado para utilizar información de estado no cifrada, un atacante podría explotar esta vulnerabilidad para ejecutar cualquier código que resida en el classpath del servidor.
  • Las instalaciones de IBM WebSphere Application Server que utilizan Form Login podrían permitir que un atacante remoto realizara ataques de spoofing. Se ha asignado el identificador CVE-2018-1695 para esta vulnerabilidad.
  • IBM WebSphere Application Server podría proporcionar una seguridad más débil de lo esperado bajo ciertas condiciones. Esto podría resultar en un ataque de downgrade del protocolo TLS. Un atacante remoto podría explotar esta vulnerabilidad para realizar ataques man-in-the-middle. Se ha asignado el identificador CVE-2018-1719 para esta vulnerabilidad.
  • WebSphere Application Server Liberty podría permitir a un atacante remoto obtener información confidencial, causada por un transporte incorrecto cuando Liberty está configurado para utilizar JASPIC (Java Authentication SPI for Containers). Esto puede ocurrir cuando el servidor de aplicaciones está configurado para permitir el acceso en un puerto no seguro (http) y utilizando autenticación JASPIC o JSR375. Se ha asignado el identificador CVE-2018-1755 para esta vulnerabilidad.
  • IBM WebSphere Application Server Liberty podría permitir a un atacante remoto obtener información confidencial, causada por el fallo en la encriptación de la comunicación ORB (Object Request Broker). Se ha asignado el identificador CVE-2018-1683 para esta vulnerabilidad.
  • IBM WebSphere Application Server en IBM Cloud podría permitir a un atacante remoto obtener información confidencial causada por el manejo inadecuado de contraseñas. Se ha asignado el identificador CVE-2018-1838 para esta vulnerabilidad.

Encuesta valoración