Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en GitLab

Múltiples vulnerabilidades en GitLab

Fecha de publicación: 
01/04/2022
Importancia: 
5 - Crítica
Recursos afectados: 

Todas las versiones de:

  • GitLab CE/EE,
  • GitLab Omnibus,
  • GitLab Charts,
  • GitLab Pages.
Descripción: 

GitLab ha publicado 17 vulnerabilidades: 1 de severidad crítica, 2 de severidad elevada, 9 de severidad media y 5 de severidad baja, por las que un atacante podría acceder a credenciales, ejecutar una vulnerabilidad tipo Cross-Site Scripting (XSS), acceder al token de registro y variables de entorno o causar una denegación de servicio entre otros.

Solución: 

Actualizar a las últimas versiones disponibles los diferentes productos afectados.

Detalle: 
  • Existe una vulnerabilidad critica al establecerse una contraseña codificada para las cuentas registradas con un proveedor de OmniAuth (p. ej., OAuth, LDAP y SAML) en GitLab CE/EE, por la que un posible atacante podría acceder a la información de las cuentas y contraseñas estáticas configuradas. Se ha asignado el identificador CVE-2022-1162 para esta vulnerabilidad.

Para el resto de vulnerabilidades se han asignado los identificadores CVE-2022-1175, CVE-2022-1190, CVE-2022-1185, CVE-2022-1148, CVE-2022-1121, CVE-2022-1120, CVE-2022-1100, CVE-2022-1193, CVE-2022-1105, CVE-2022-1099, CVE-2022-1174, CVE-2022-1188, CVE-2022-0740, CVE-2022-1189, CVE-2022-1157 y CVE-2022-1111.

Encuesta valoración