Inicio / Alerta Temprana / Avisos Seguridad / Múltiples vulnerabilidades en el core de Drupal

Múltiples vulnerabilidades en el core de Drupal

Fecha de publicación: 
19/12/2019
Importancia: 
4 - Alta
Recursos afectados: 
  • 7.x,
  • 8.8.x,
  • 8.7.x
Descripción: 

El equipo de seguridad de Drupal ha detectado múltiples vulnerabilidades en el core que, entre otros, podrían permitir a un atacante la denegación del servicio, saltarse las protecciones del archivo .htaccess o acceder a elementos multimedia protegidos.

Solución: 

Actualizar a las versiones 7.69, 8.8.1 y 8.7.11.

Detalle: 
  • Existen múltiples vulnerabilidades de severidad alta cuando Drupal está configurado para permitir que los archivos .tar, .tar.gz, .bz2 o .tlz se carguen y procesen, debido a una vulnerabilidad en la biblioteca de terceros Archive_Tar.
  • El módulo de biblioteca multimedia no restringe suficientemente el acceso a elementos multimedia en determinadas configuraciones.
  • La función file_save_upload() del núcleo de Drupal 8 no elimina el punto inicial y final ('.') de los nombres de archivo. Los usuarios con la capacidad de subir archivos con cualquier extensión junto con los módulos contribuidos pueden aprovechar esta vulnerabilidad para subir archivos de sistema como .htaccess, evitando las protecciones ofrecidas por el archivo .htaccess predeterminado de Drupal.
  • Acceder al archivo install.php puede causar que los datos de la caché se corrompan y que el portal se vea afectado hasta que se reconstruyan las mismas.

Encuesta valoración