Inicio / Alerta Temprana / Avisos Seguridad / Ejecución remota de código en AJP de Apache Tomcat

Ejecución remota de código en AJP de Apache Tomcat

Fecha de publicación: 
25/02/2020
Importancia: 
4 - Alta
Recursos afectados: 

Apache Tomcat, versiones:

  • desde 7.0.0 hasta 7.0.99,
  • desde 8.5.0 hasta 8.5.50,
  • desde 9.0.0.M1 hasta 9.0.30.
Descripción: 

El equipo de seguridad de Apache Tomcat detectó una vulnerabilidad, de severidad alta, en Apache JServ Protocol (AJP), que podría permitir a un atacante realizar una ejecución remota de código.

Solución: 

Actualizar a las siguientes versiones:

Detalle: 

Apache Tomcat trata las conexiones AJP como si tuvieran un mayor nivel de confianza que, por ejemplo, una conexión similar de HTTP. Si un atacante tuviera acceso a esas conexiones, podría realizar una ejecución remota de código que le otorgaría acceso a archivos arbitrarios de cualquier parte de la aplicación web. Se ha asignado el identificador CVE-2020-1938 para esta vulnerabilidad.

Encuesta valoración