Inicio / Alerta Temprana / Avisos Seguridad / Actualización de seguridad de SAP de noviembre de 2020

Actualización de seguridad de SAP de noviembre de 2020

Fecha de publicación: 
11/11/2020
Importancia: 
5 - Crítica
Recursos afectados: 
  • SAP Solution Manager (JAVA stack y User Experience Monitoring), versión 7.2;
  • SAP Data Services, versión 4.2;
  • SAP AS ABAP(DMIS), versiones 2011_1_620, 2011_1_640, 2011_1_700, 2011_1_710, 2011_1_730, 2011_1_731, 2011_1_752 y 2020;
  • SAP S4 HANA, versiones 100, 101, 102, 103, 104 y 105;
  • SAP NetWeaver, versiones 7.20, 7.30, 7.31, 7.40, 7.50, 7.51, 7.52, 7.53, 7.54, 7.55 y 7.82;
  • SAP Fiori Launchpad (News Tile Application), versiones 750, 751, 752, 753, 754 y 755;
  • SAP Commerce Cloud, versiones 1808, 1811, 1905 y 2005;
  • BANKING SERVICES FROM SAP 9.0 (Bank Analyzer), versión 500;
  • S/4HANA FIN PROD SUBLDGR, versión 100;
  • SAP Process Integration (PGP Module – Business-to-Business Add On), versión 1.0;
  • SAP ERP Client para E-Bilanz 1.0, versión 1.0;
  • SAP ERP, versiones 600, 602, 603, 604, 605, 606, 616, 617 y 618;
  • SAP 3D Visual Enterprise Viewer, versión 9.
Descripción: 

SAP ha publicado varias actualizaciones de seguridad de diferentes productos en su comunicado mensual.

Solución: 

Visitar el portal de soporte de SAP e instalar las actualizaciones o los parches necesarios, según indique el fabricante.

Detalle: 

SAP, en su comunicación mensual de parches de seguridad, ha emitido un total de 12 notas de seguridad y 3 actualizaciones de notas anteriores, siendo 6 de las nuevas notas de severidad crítica, 3 altas y 6 medias.

Los tipos de vulnerabilidades publicadas se corresponden con los siguientes:

  • 5 vulnerabilidades de falta de comprobación de autenticación,
  • 4 vulnerabilidades de divulgación de información,
  • 3 vulnerabilidades de falta de comprobación de autorización,
  • 2 vulnerabilidades de denegación de servicio (DoS),
  • 1 vulnerabilidad de inyección de código,
  • 1 vulnerabilidad de inyección de comandos en el SSOO,
  • 1 vulnerabilidad de ejecución remota de código (RCE),
  • 4 vulnerabilidades de otro tipo.

Las notas de seguridad más destacadas se refieren a:

  • Estas vulnerabilidades críticas, de falta de autenticación, tienen un impacto negativo en la integridad y disponibilidad del servicio LM-Service, así como de cuatro servicios dependientes. Se han asignado los identificadores CVE-2020-26821, CVE-2020-26822, CVE-2020-26823 y CVE-2020-26824 para estas vulnerabilidades.
  • SAP Solution Manager, debido a la falta de verificación de autenticación, no realiza ninguna autenticación para un servicio, lo que podría resultar en un compromiso completo de todos los agentes SMDA conectados al Solution Manager. Se ha asignado el identificador CVE-2020-6207 para esta vulnerabilidad.
  • Una validación de entrada insuficiente podría permitir que un atacante, no autenticado, enviase solicitudes maliciosas que podrían resultar en la ejecución remota de código y, por lo tanto, en un compromiso total de la confidencialidad, integridad y disponibilidad del sistema. Se han asignado los identificadore CVE-2019-0230 y CVE-2019-0233 para estas vulnerabilidades.
  • SAP AS ABAP (DMIS) podría permitir a un atacante autenticado inyectar código arbitrario en el módulo de función, lo que resultaría en una inyección de código que se podría ejecutar en la aplicación, afectando a la confidencialidad, disponibilidad e integridad de la aplicación. Se ha asignado el identificador CVE-2020-26808 para esta vulnerabilidad.
  • El parche corrige un error en SAP NetWeaver Application Server Java que podría permitir que los usuarios autenticados en SAP escalasen a los comandos del sistema operativo en el vulnerable y, por lo tanto, lograsen comprometer totalmente cada servicio y pieza de información en ejecución. Se ha asignado el identificador CVE-2020-26820 para esta vulnerabilidad.
  • SAP NetWeaver (Knowledge Management) podría permitir la ejecución automática del contenido del script en un archivo almacenado debido a un filtrado inadecuado con los privilegios del usuario que accede. Si dicho usuario tiene privilegios administrativos, entonces la ejecución del contenido del script podría resultar en un compromiso total de la confidencialidad, integridad y disponibilidad del sistema, lo que conduciría a un XSS almacenado. Se ha asignado el identificador CVE-2020-6284 para esta vulnerabilidad.

Para el resto de vulnerabilidades se han asignado los identificadores: CVE-2020-26825, CVE-2020-26809, CVE-2020-26811, CVE-2020-26819, CVE-2020-6311, CVE-2020-26814, CVE-2020-26807, CVE-2020-6316 y CVE-2020-26817.

Encuesta valoración