Inicio / Alerta Temprana / Avisos Seguridad / 21 Nails: Múltiples vulnerabilidades en Exim Mail Server

21 Nails: Múltiples vulnerabilidades en Exim Mail Server

Fecha de publicación: 
05/05/2021
Importancia: 
5 - Crítica
Recursos afectados: 

Exim Mail Server, todas las versiones anteriores a Exim-4.94.2.

Descripción: 

El equipo de investigación de Qualys ha descubierto múltiples vulnerabilidades críticas en el servidor de correo Exim. Un atacante podría combinar alguna de ellas para obtener la ejecución remota completa de código sin necesidad de autenticación y obtener así privilegios de root.

Solución: 

Actualizar a Exim-4.94.2.

Detalle: 
  • Once vulnerabilidades pueden ser explotadas localmente. La mayoría de ellas podrían ser explotadas en las configuraciones por defecto o configuraciones muy comunes. Algunas de ellas pueden combinarse para ejecutar código remoto sin necesidad de autenticación y obtener privilegios de root en el servidor Exim:
    • CVE-2020-28007: ataque de enlace en el directorio log de Exim (link attack);
    • CVE-2020-28008: ataques variados en el directorio spool de Exim;
    • CVE-2020-28014: creación arbitraria de archivos PID;
    • CVE-2020-28011: desbordamiento de búfer basado en montículo (heap) en queue_run();
    • CVE-2020-28010: escritura fuera de límites en montículo (heap) en main();
    • CVE-2020-28013: desbordamiento de búfer basado en montículo (heap) en parse_fix_phrase();
    • CVE-2020-28016: escritura fuera de límites en montículo (heap) en parse_fix_phrase();
    • CVE-2020-28015: inyección de nueva línea en archivo de cabecera spool (local);
    • CVE-2020-28012: falta de la flag 'close-on-exec' en tuberías con privilegios;
    • CVE-2020-28009: desbordamiento de enteros en get_stdinput();
  • Diez de las vulnerabilidades pueden ser explotadas remotamente. Algunas de ellas podrían permitir a un atacante obtener privilegios de root en el sistema remoto:
    • CVE-2020-28017: desbordamiento de enteros en receive_add_recipient();
    • CVE-2020-28020: desbordamiento de enteros en receive_msg();
    • CVE-2020-28023: lectura fuera de límites en smtp_setup_msg();
    • CVE-2020-28021: inyección de nueva línea en archivo de cabecera spool (remoto);
    • CVE-2020-28022: lectura y escritura de montículo (heap) fuera de límites en extract_option();
    • CVE-2020-28026: truncado de línea e inyección en spool_read_header();
    • CVE-2020-28019: fallo en el restablecimiento del puntero de la función tras un error BDAT;
    • CVE-2020-28024: decremento del puntero o del index a una posición anterior al búfer (heap buffer underflow) en smtp_ungetc();
    • CVE-2020-28018: uso de la memoria previamente liberada en tls-openssl.c;
    • CVE-2020-28025: lectura de memoria dinámica (heap) fuera de límites en pdkim_finish_bodyhash().

Encuesta valoración