Inicio / Alerta Temprana / Avisos Sci / Vulnerabilidad en productos de HIMA

Vulnerabilidad en productos de HIMA

Fecha de publicación: 
17/01/2023
Identificador: 
INCIBE-2023-0016
Importancia: 
4 - Alta
Recursos afectados: 
  • HOPCS, versiones 3.56.4 y anteriores;
  • X-OPC A+E, versiones 5.6.1210 y anteriores;
  • X-OPC DA, versiones 5.6.1210 y anteriores;
  • X-OTS, versiones 1.32.550 y anteriores.
Descripción: 

CERT@VDE, coordinado con HIMA, ha publicado un aviso que contiene 1 vulnerabilidad de severidad alta. La explotación de esta vulnerabilidad podría permitir al atacante obtener privilegios y acceso completo al sistema.

Solución: 

HIMA recomienda:

  • Ejecutar el servidor OPC y el entorno de programación en diferentes PC.
  • Asegúrese de que solo se pueda acceder al registro con privilegios de administrador.
  • Instalar HOPCS en una ruta sin espacios y/o seleccionar un usuario con privilegios bajos en la configuración de DCOM dcomcnfg/Identity.
  • Al utilizar X-OPC o X-OTS se recomienda proteger el programa de usuario, con las variables del sistema (ver ‘Manual de seguridad en automatismos’, apartado 3.2.2.2: ‘Restricciones de Acceso’).
Detalle: 

La vulnerabilidad de severidad alta podría permitir a un usuario local obtener privilegios a través de un archivo .exe malicioso y obtener acceso completo al sistema.

Se ha asignado el identificador CVE-2022-4258 para esta vulnerabilidad.

Encuesta valoración