Inicio / Alerta Temprana / Avisos Sci / Vulnerabilidad de lectura fuera de límites en CNCSoft de Delta Electronics

Vulnerabilidad de lectura fuera de límites en CNCSoft de Delta Electronics

Fecha de publicación: 
20/02/2019
Importancia: 
3 - Media
Recursos afectados: 
  • CNCSoft ScreenEditor, versión 1.00.84 y anteriores.
Descripción: 

Natnael Samson, trabajando con Zero Day Initiative de Trend Micro, ha identificado una vulnerabilidad de tipo lectura fuera de límites. Un atacante podría causar un desbordamiento de búfer que le permitiría divulgar información o bloquear la aplicación.

Solución: 
  • Actualizar CNCSoft ScreenEditor a la versión 1.01.15 y restringir la interacción con la ampliación a ficheros confiables.
Detalle: 
  • Una vulnerabilidad de lectura fuera de límites podría permitir a un atacante bloquear el software debido a la falta de validación de entrada del usuario para procesar los archivos de proyecto. Se ha reservado el identificador CVE-2019-6547 para esta vulnerabilidad.

Encuesta valoración