Inicio / Alerta Temprana / Avisos Sci / Vulnerabilidad de denegación de servicio en TOYOPUC PLC de JTEKT Corporation

Vulnerabilidad de denegación de servicio en TOYOPUC PLC de JTEKT Corporation

Fecha de publicación: 
30/06/2021
Importancia: 
3 - Media
Recursos afectados: 

Están afectados por esta vulnerabilidad las siguientes versiones de TOYOPUC PLC:

  • PC10G-CPU
  • 2PORT-EFR
  • Plus CPU
  • Plus EX
  • Plus EX2
  • Plus EFR
  • Plus EFR2
  • Plus 2P-EFR
  • PC10P-DP
  • PC10P-DP-IO
  • Plus BUS-EX
  • Nano 10GX
  • Nano 2ET
  • PC10PE
  • PC10PE-16/16P
  • PC10E
  • FL/ET-T-V2H
  • PC10B
  • PC10B-P
  • Nano CPU
  • PC10P
  • PC10GE
Descripción: 

El investigador, Chris Yang, a través de Trend Micro’s Zero Day Initiative, ha identificado una vulnerabilidad de denegación de servicio por una restricción inadecuada de los límites de un búfer de memoria, lo que podría bloquear el dispositivo afectado.

Solución: 

JTEKT ha publicado en su página web nuevas versiones de firmware de los PLC afectados que solucionan esta vulnerabilidad:

  • PC10G-CPU: versión 3.91 o posteriores;
  • 2PORT-EFR: versión 1.50 o posteriores;
  • PC10P-DP: versión 1.50 o posteriores;
  • PC10P-DP-IO: versión 1.50 o posteriores;
  • Nano 10GX: versión 3.00 o posteriores;
  • Nano 2ET: versión 2.40 o posteriores;
  • PC10PE: versión 1.02 o posteriores;
  • PC10PE-16 / 16P: versión 1.02 o posteriores;
  • PC10E: versión 1.12 o posteriores;
  • FL / ET-T-V2H: versión F2.8 E1.5 o posteriores;
  • PC10B: versión 1.11 o posteriores;
  • PC10B-P: versión 1.11 o posteriores;
  • Nano CPU: versión 2.08 o posteriores;
  • PC10P: versión 1.05 o posteriores;
  • PC10GE: versión 1.04 o posteriores;
  • Plus CPU: versión 3.11 o posteriores;
  • Plus EX: versión 3.11 o posteriores;
  • Plus EX2: versión 3.11 o posteriores;
  • Plus EFR: versión 3.11 o posteriores;
  • Plus EFR2: versión 3.11 o posteriores;
  • Plus 2P-EFR: versión 3.11 o posteriores;
  • Plus BUS-EX: versión 2.13 o posteriores.
Detalle: 

La vulnerabilidad descubierta se produce cuando los productos afectados reciben una trama no válida y se sobrescribe fuera de un búfer de recepción para FL-net. Debido a esto, la CPU del PLC detecta un error del sistema y los productos afectados se detienen. Se ha asignado para esta vulnerabilidad el identificador CVE-2021-27477.

Encuesta valoración