Inicio / Alerta Temprana / Avisos Sci / Vulnerabilidad de corrupción de memoria en CX-Programmer de Omron

Vulnerabilidad de corrupción de memoria en CX-Programmer de Omron

Fecha de publicación: 
05/04/2019
Importancia: 
3 - Media
Recursos afectados: 
  • CX-Programmer, versión 9.70 y anteriores.
  • Common Components, versión de enero de 2019 y anteriores.
Descripción: 

El investigador Esteban Ruiz de Source Incite, trabajando con Zero Day Initiative de Trend Micro, ha identificado una vulnerabilidad de uso de recursos después de la liberación de memoria en productos CX-Programmer de Omron.

Solución: 
  • CX-Programmer, versión 9.71
  • Common Components, versión de abril de 2019
Detalle: 
  • Un potencial atacante podría utilizar un archivo de proyecto especialmente manipulado para explotar y ejecutar código bajo los privilegios de la aplicación, aprovechando referencias a memoria liberada. Se ha reservado el identificador CVE-2019-6556 para esta vulnerabilidad.

Encuesta valoración