Inicio / Alerta Temprana / Avisos Sci / Validación de entrada incorrecta en múltiples productos de Rockwell Automation

Validación de entrada incorrecta en múltiples productos de Rockwell Automation

Fecha de publicación: 
03/03/2021
Importancia: 
3 - Media
Recursos afectados: 

Las siguientes versiones de dispositivos de Rockwell Automation están afectadas:

  • controladores Armor Compact GuardLogix 5370, versiones 33 y anteriores;
  • controladores de seguridad Armor GuardLogix, versiones 33 y anteriores;
  • controladores CompactLogix 5370 L1, versiones 33 y anteriores;
  • controladores CompactLogix 5370 L2s, versiones 33 y anteriores;
  • controladores CompactLogix 5370 L3, versiones 33 y anteriores;
  • controladores Compact GuardLogix 5370, versiones 33 y anteriores;
  • controladores ControlLogix 5570, versiones 33 y anteriores.
Descripción: 

El investigador, Yeop Chang, ha reportado una vulnerabilidad, de severidad media, de tipo validación de entrada incorrecta, que podría afectar a múltiples controladores de Rockwell Automation,

Solución: 

Rockwell Automation recomienda a los usuarios afectados que actualicen el firmware a la versión 33.011 o posterior.

Detalle: 

El algoritmo para establecer la conexión, utilizado por CompactLogix 5370 y ControlLogix 5570, no gestiona correctamente su flujo de control durante la ejecución, creando un bucle infinito. Esto podría permitir a un atacante enviar solicitudes de paquetes CIP (Common Industrial Protocol), especialmente diseñados, a un controlador, provocando condiciones de denegación de servicio en las comunicaciones con otros productos. Se ha asignado el identificador CVE-2020-6998 para esta vulnerabilidad.

Encuesta valoración