Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en WebAccess de Advantech

Múltiples vulnerabilidades en WebAccess de Advantech

Fecha de publicación: 
18/09/2019
Importancia: 
5 - Crítica
Recursos afectados: 

WebAccess, versiones 8.4.1 y anteriores.

Descripción: 

Los investigadores Peter Cheng de Elextec Security Tech. Co., Ltd. y Mat Powell de Trend Micro’s Zero Day Initiative, junto con ADLab de VenusTech, han identificado varias vulnerabilidades de tipo inyección de código, inyección de comandos, desbordamiento de la pila del búfer y autorización impropia, que podrían permitir a un atacante ejecutar código arbitrario, acceder a los archivos y ejecutar acciones con un nivel de privilegios elevado, o borrar archivos en el sistema.

Solución: 

Advantech ha liberado la versión 8.4.2 de WebAccessNode para solucionar las vulnerabilidades descritas.

Detalle: 
  • La ejecución de un exploit en la red podría causar un control incorrecto de la generación de código, lo que permitiría la ejecución de código remoto, exfiltración de datos o causar el bloqueo del sistema. Se ha reservado el identificador CVE-2019-13558 para esta vulnerabilidad.
  • Múltiples vulnerabilidades de inyección de comandos son causadas por una falta de validación de los datos provistos por el usuario, lo que permitiría la eliminación arbitraria de archivos y la ejecución de código remoto. Se ha reservado el identificador CVE-2019-13552 para esta vulnerabilidad.
  • Múltiples vulnerabilidades de desbordamiento de búfer basado en pila son causadas por la falta de validación adecuada de la longitud de los datos provistos por el usuario, lo que podría permitir la ejecución de código remoto. Se ha reservado el identificador CVE-2019-13556 para esta vulnerabilidad.
  • Una vulnerabilidad de autorización impropia permitiría a un atacante revelar información sensible y provocar un control incorrecto de la generación de código, lo que podría permitir la ejecución de código remoto o producir el bloqueo del sistema. Se ha reservado el identificador CVE-2019-13550 para esta vulnerabilidad.

Encuesta valoración