Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en varios productos de General Electric

Múltiples vulnerabilidades en varios productos de General Electric

Fecha de publicación: 
23/09/2020
Importancia: 
4 - Alta
Recursos afectados: 
  • GE Digital APM Classic, versiones 4.4 y anteriores;
  • GE Reason S20 Ethernet Switch, versiones:
    • S2020, todas las versiones de firmware anteriores a 07A06;
    • S2024, todas las versiones de firmware anteriores a 07A06;
Descripción: 

Guido Marilli, investigador de Accenture Security, y la compañía IOActive han reportado a GE 4 vulnerabilidades, 2 con severidad alta y 2 medias, de tipo omisión de autorización mediante clave controlada por el usuario, uso de un hash unidireccional sin salt y XSS.

Solución: 
Detalle: 
  • Una vulnerabilidad IDOR (Insecure Direct Object Reference) podría permitir que un atacante descargase datos confidenciales relacionados con cuentas de usuario sin tener los privilegios adecuados. Se ha asignado el identificador CVE-2020-16240 para esta vulnerabilidad.
  • Salt (datos aleatorios utilizados como entrada adicional a una función unidireccional que utiliza el hash de datos, una contraseña o una frase de contraseña) no se utiliza para el cálculo hash de contraseñas, lo que podría permitir descifrarlas, poniendo a toda la plataforma en riesgo, ya que un usuario autenticado podría recuperar todos los datos de la cuenta de usuario y luego obtener las contraseñas reales. Se ha asignado el identificador CVE-2020-16244 para esta vulnerabilidad.
  • El producto afectado es vulnerable a XSS (Cross-Site Scripting), que podría permitir que un atacante engañase a los usuarios para que realizasen acciones críticas que incluyen, entre otras, agregar y actualizar cuentas. Se ha asignado el identificador CVE-2020-16242 para esta vulnerabilidad.
  • El producto afectado es vulnerable a XSS, que podría permitir a los atacantes engañar a los usuarios para que sigan un enlace o naveguen a una página con código JavaScript malicioso, lo que haría que dicho código sea procesado y ejecutado por la víctima. Se ha asignado el identificador CVE-2020-16246 para esta vulnerabilidad.

Encuesta valoración