Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en SiteOmat de Orpak

Múltiples vulnerabilidades en SiteOmat de Orpak

Fecha de publicación: 
03/05/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • SiteOmat, versiones anteriores a la 6.4.414.122
  • SiteOmat, versiones anteriores a la 6.4.414.084
Descripción: 

El investigador Ido Naor de Kaspersky Lab ha reportado varias vulnerabilidades de tipo uso de contraseñas embebidas, Cross-Site Scripting (XSS), Inyección SQL, falta de cifrado en datos sensibles, inyección de código y desbordamiento de búfer. La explotación exitosa de estas vulnerabilidades permitiría a un atacante ejecutar código remoto originando una posible denegación de servicio y acceso no autorizado para ver y editar información de monitorización, configuración y pago.

Solución: 
  • El fabricante recomienda actualizar las versiones afectadas a la versión v6.4.414.139 o posterior. La actualización puede obtenerse contactando con el fabricante en la página de soporte de Orpak (requiere registro previo).
Detalle: 
  • Uso de contraseñas embebidas: la aplicación utiliza credenciales embebidas. Se ha reservado el identificador CVE-2017-14728 para esta vulnerabilidad.
  • Cross-Site Scripting (XSS): la aplicación web no realiza un correcto filtrado de los parámetros de entrada, este hecho permite la explotación de Cross-Site Scripting. Se ha asignado el identificador CVE-2017-14850 para esta vulnerabilidad.
  • Inyección SQL: la aplicación no realiza el correcto filtrado de los parámetros de entrada. Este hecho podría permitir a un atacante acceder a información del producto mediante la introducción de una entrada especialmente diseñada. Se ha reservado el identificador CVE-2017-14851 para esta vulnerabilidad.
  • Falta de cifrado en datos sensibles: la aplicación envía información sensible en texto plano. Entre la información sensible enviada, se encuentran credenciales. Un atacante podría capturar las credenciales enviadas por red y saltarse la autenticación del producto afectado. Se ha reservado el identificador CVE-2017-14852 para esta vulnerabilidad.
  • Inyección de código: la aplicación no restringe adecuadamente los parámetros de entrada externos. Este hecho permitiría a un atacante no autenticado ejecutar código especialmente diseñado en el sistema víctima. Se ha reservado el identificador CVE-2017-14853 para esta vulnerabilidad.
  • Desbordamiento de búfer: la aplicación utiliza una función que acepta parámetros de entrada de usuarios. Dicha entrada no posee un correcto tratamiento por lo que un atacante podría ejecutar código arbitrario. Se ha reservado el identificador CVE-2017-14854 para esta vulnerabilidad.

Encuesta valoraciĂ³n

Etiquetas: