Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en RSLinx Classic de Rockwell Automation

Múltiples vulnerabilidades en RSLinx Classic de Rockwell Automation

Fecha de publicación: 
21/09/2018
Importancia: 
5 - Crítica
Recursos afectados: 
  • RSLinx Classic versión 4.00.01 y anteriores.
Descripción: 

Rockwell Automation, en colaboración con Tenable y Younes Dragoni de Nozomi Networks, ha reportado varias vulnerabilidades de tipo desbordamiento de búfer y consumo de recursos descontrolado. La explotación exitosa de estas vulnerabilidades podría bloquear el acceso al dispositivo o permitir la ejecución de código en el dispositivo afectado.

Solución: 
  • Rockwell Automation ha publicado una nueva versión del software que mitiga las vulnerabilidades. Esta nueva versión puede ser descargada en su plataforma tras un registro previo en el siguiente enlace:
    • https://rockwellautomation.custhelp.com/app/answers/detail/a_id/1075712
  • Rockwell Automation también recomienda deshabilitar el puerto 44818/tcp si es posible en el caso de no estar utilizando estas comunicaciones.
Detalle: 
  • Una vulnerabilidad de desbordamiento de búfer podría permitir a un atacante remoto enviar un paquete CIP malformado al puerto 44818, causando que la aplicación software deje de responder y se detenga. Además, esta vulnerabilidad también podría permitiría permitir ejecutar código de manera remota gracias a un desbordamiento de búfer. Se ha reservado el identificador CVE-2018-14829 para esta vulnerabilidad.
  • Una vulnerabilidad de desbordamiento de búfer podría permitir a un atacante remoto no autenticado enviar un paquete CIP malformado al puerto 44818 con el objetivo de causar denegaciones de servicio en la aplicación Classic de RSLinx. El usuario tendrá que reiniciar el software manualmente para que vuelva a funcionar de forma correcta. Se ha reservado el identificador CVE-2018-14821 para esta vulnerabilidad.
  • Un atacante remoto sin autentificación podría enviar paquetes Ethernet/IP especialmente diseñados al puerto 44818, causando que la aplicación deje de responder y se detenga debido a un consumo de recursos descontrolado. El usuario debe reiniciar el software para recuperar la funcionalidad. Se ha reservado el identificador CVE-2018-14827 para esta vulnerabilidad.

Encuesta valoración