Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en Rockwell Automation FactoryTalk

Múltiples vulnerabilidades en Rockwell Automation FactoryTalk

Fecha de publicación: 
19/06/2020
Importancia: 
5 - Crítica
Recursos afectados: 

Se encuentran afectados por estas vulnerabilidades todas las versiones de FactoryTalk View SE y todas las versiones de FactoryTalk Services Platform.

Descripción: 

Rockwell Automation, junto con Trend Micro’s Zero Day Initiative, han publicado 5 vulnerabilidades, una de severidad crítica, 3 altas y una media, que permitirían que un atacante autenticado remoto manipule los datos de los dispositivos afectados, o que ejecute objetos COM remotos con privilegios elevados.

Solución: 

Para FactoryTalk View SE se recomienda instalar los parches 1126289 y 1126289. Antes de instalar dichos parches se debe aplicar el parche acumulativo 1066644 - Parche Roll-up para CPR9 SRx del 6 de abril de 2020.

Rockwell Automation recomienda también para FactoryTalk View SE habilitar las funciones de seguridad integradas, siguiendo la guía de los artículos 109056 y 1126943 de su base de conocimiento para configurar IPSec y / o HTTP.

En el caso de FactoryTalk Services Platform se recomienda utilizar el artículo 25612 de la base de conocimientos de Rockwell, para determinar si este producto está instalado. En cuyo caso se deben implementar una estrategia de comunicación segura como la indicada en el artículo 109056 de la base de conocimientos.

Detalle: 

Las vulnerabilidades encontradas en los productos de Rockwell Automation podrían permitir a un atacante acceder a información confidencial o no autorizada, realizar operaciones no permitidas dentro de los límites de un buffer de memoria, o modificar los permisos, controles y privilegios de acceso.

La vulnerabilidad más crítica de las encontradas (CVE-2020-12029) se produce al no validar correctamente el nombre de archivos dentro de un directorio del proyecto, pudiendo un atacante remoto no autenticado ejecutar un archivo diseñado y provocar una ejecución remota de código (RCE).

Los identificadores reservados a estas vulnerabilidades son CVE-2020-12029, CVE-2020-12031, CVE-2020-12028, CVE-2020-12027 y CVE-2020-12033.

Encuesta valoración