Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en ProSyst mBS SDK y IoT Gateway Software de Bosch

Múltiples vulnerabilidades en ProSyst mBS SDK y IoT Gateway Software de Bosch

Fecha de publicación: 
20/08/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • ProSyst mBS SDK, versiones anteriores a la 8.2.6;
  • Bosch IoT Gateway Software, versiones anteriores a la 9.0.2, 9.2.0 y la 9.3.0.
Descripción: 

Se han identificado múltiples vulnerabilidades del tipo salto de ruta, Server-Side Request Forgery (SSRF) y exposición de información en los productos afectados, que podrían permitir, a un atacante remoto, acceder a información sensible, escribir y borrar información del sistema y enviar una petición GET de HTTP en nombre del servidor.

Solución: 

Actualizar ProSyst mBS SDK a la versión 8.2.6 e IoT Gateway a la versión 9.3.0.

Detalle: 
  • Una vulnerabilidad de tipo salto de ruta en el acceso remoto a la función Backup/Restore, podría permitir a un atacante remoto escribir y borrar ficheros de cualquier localización. Se ha asignado el identificador CVE-2019-11601 para esta vulnerabilidad.
  • Una vulnerabilidad del tipo Server-Side Request Forgery (SSRF) en la función Backup/Restore, podría permitir a un atacante falsificar peticiones GET a URLs arbitrarias o leer ficheros zip del servidor local. Se ha asignado el identificador CVE-2019-11897 para esta vulnerabilidad.
  • La filtración de las trazas de la pila en los accesos remotos de la función Backup/Restore podría permitir, a un atacante en remoto, la obtención de información sobre la estructura del sistema. Se ha asignado el identificador CVE-2019-11602 para esta vulnerabilidad.
  • Una vulnerabilidad de salto de ruta HTTP podría permitir, a un atacante, la lectura de ficheros fuera de la raíz del servidor web. Se ha asignado el identificador CVE-2019-11603 para esta vulnerabilidad.

Encuesta valoración