Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos Siemens

Múltiples vulnerabilidades en productos Siemens

Fecha de publicación: 
10/12/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • SPPA-T3000 Application Server, todas las versiones, 
  • SPPA-T3000 MS3000 Migration Server, todas las versiones,
  • Módulo EN 100 Ethernet,
    • variante IEC 61850, todas las versiones anteriores a la V4.37,
    • variante PROFINET IO, todas las versiones,
    • variante Modbus TCP, todas las versiones,
    • variante DNP3, todas las versiones,
    • variante IEC 104, todas las versiones.
  • XHQ, todas las versiones anteriores a la V6.0.0.2,
  • SCALANCE W1700, todas las versiones anteriores a la V1.1,
  • SCALANCE W700, todas las versiones anteriores a la V6.4,
  • SiNVR 3 Central Control Server (CCS), todas las versiones,
  • SiNVR 3 Video Server, todas las versiones,
  • RUGGEDCOM ROS: 
    • RMC8388, todas las versiones,
    • RSG2488, todas las versiones,
    • RSG920P, todas las versiones,
    • RSG9xx R/C, todas las versiones,
    • RSL910, todas las versiones,
    • RST2228, todas las versiones.
Descripción: 

Siemens ha detectado múltiples vulnerabilidades en algunos de sus dispositivos. Un atacante remoto podría revelar información, realizar una escalada de privilegios, evadir rutas, ejecutar código arbitrario, provocar una condición de denegación de servicio o realizar una inyección de datos.

Solución: 

Siemens ha publicado diversas actualizaciones en función del dispositivo afectado:​​​​​

  • SPPA-T3000 Application Server, el parche Service Pack R8.2 SP1.
  • Módulo EN 100 Ethernet, variante IEC 61850, actualizar a la versión V4.37.
  • XHQ, actualizar a la versión V6.0.0.2.
  • SCALANCE W1700, actualizar a la versión V1.1.
  • SCALANCE W700, actualizar a la versión V6.4.

Para el resto de los productos afectados, consultar las recomendaciones de la sección Workarounds and Mitigations de los avisos oficiales de Siemens.

Detalle: 

A continuación, se incluye el detalle de las vulnerabilidades críticas:

  • Autenticación inadecuada. Se han asignado los identificadores CVE-2019-18337, CVE-2019-18284, CVE-2019-18314, CVE-2019-18315, CVE-2019-18321 y CVE-2019-18322 para estas vulnerabilidades.
  • Falta de autenticación en función crítica. Se ha asignado el identificador CVE-2019-18339 para esta vulnerabilidad. 
  • Exposición de función o método peligroso. Se ha asignado el identificador CVE-2019-18342 para esta vulnerabilidad.
  • Deserialización de datos no confiables. Se han asignado los identificadores CVE-2019-18283 y CVE-2019-18316 para estas vulnerabilidades.
  • Ausencia de validación en la subida de ficheros. Se ha asignado el identificador CVE-2019-18313 para esta vulnerabilidad.
  • Desbordamiento de búfer basado en memoria dinámica (Heap). Se han asignado los identificadores CVE-2019-18323, CVE-2019-18324, CVE-2019-18325, CVE-2019-18326, CVE-2019-18327, CVE-2019-18328, CVE-2019-18329, CVE-2019-18330, CVE-2019-18289 y CVE-2019-18293 para estas vulnerabilidades.

Para el resto de las vulnerabilidades se han asignado los identificadores CVE-2019-13942, CVE-2019-13943, CVE-2019-13944, CVE-2018-14526, CVE-2019-13947, CVE-2019-18338, CVE-2019-18340, CVE-2019-18341, CVE-2018-18440, CVE-2019-13103, CVE-2019-13930, CVE-2019-13931, CVE-2019-13932, CVE-2018-4832, CVE-2019-18285, CVE-2019-18286, CVE-2019-18287, CVE-2019-18288, CVE-2019-18290, CVE-2019-18291, CVE-2019-18292, CVE-2019-18294, CVE-2019-18295, CVE-2019-18296, CVE-2019-18297, CVE-2019-18298, CVE-2019-18299, CVE-2019-18300, CVE-2019-18301, CVE-2019-18302, CVE-2019-18303, CVE-2019-18304, CVE-2019-18305, CVE-2019-18306, CVE-2019-18307, CVE-2019-18308, CVE-2019-18309, CVE-2019-18311, CVE-2019-18312, CVE-2019-18317, CVE-2019-18318, CVE-2019-18319, CVE-2019-18320, CVE-2019-18331, CVE-2019-18332, CVE-2019-18333, CVE-2019-18334 y CVE-2019-18335.

Encuesta valoración