Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos Siemens

Múltiples vulnerabilidades en productos Siemens

Fecha de publicación: 
14/05/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • LOGO! Soft Comfort y BM, todas las versiones.
  • SCALANCE W1750D, todas las versiones anteriores a la V8.4.0.1.
  • SINAMICS PERFECT HARMONY GH180 con NXG I y NXG II control, MLFBs: 6SR2. . . -, 6SR3. . . -, 6SR4. . .-, todas las versiones con opción G28.
  • SIMATIC PCS 7 V9.0, V8.2, V8.2 y V8.0 y anteriores, todas las versiones.
  • SIMATIC WinCC (TIA Portal) V15, V14 y V13, todas las versiones.
  • SIMATIC WinCC Runtime Professional, todas las versiones.
  • SIMATIC WinCC V7.2 y anteriores, todas las versiones.
  • SIMATIC WinCC V7.3 y posteriores, todas las versiones
  • SIMATIC WinCC V7.4, V7.3 y V7.2, todas las versiones.
  • SIMATIC WinCC V7.5, todas las versiones anteriores a la versión 7,5 Upd3.
  • SIMATIC PCS 7 V8.0 y anteriores, todas las versiones.
  • SIMATIC PCS 7 V8.1 y posteriores, todas las versiones.
  • SIMATIC PCS V7.2 y todas las versiones anteriores.
  • SIMATIC WinCC V7.3 y todas las versiones posteriores.
  • SIMATIC HMI Comfort Panels 4" - 22". Todas las versiones anteriores a la V15.1 Update 1.
  • SIMATIC HMI Comfort Outdoor Panels 7" & 15". Todas las versiones anteriores a la V15.1 Update 1.
  • SIMATIC HMI KTP Mobile Panels KTP400F, KTP700, KTP700F, KTP900 und KTP900F. Todas las versiones anteriores a la V15.1 Update 1.
  • SIMATIC WinCC Runtime Advanced, Professional y TIA Portal. Todas las versiones anteriores a la V15.1 Update 1.
  • SIMATIC HMI Classic Devices (TP/MP/OP/MPMobile Panel). Todas las versiones.
  • SISHIP EMCS, IMAC y IPMS: Todas las versiones.
Descripción: 

Los investigadores Vladimir Dashchenko y Sergey Temnikov de Kaspersky Lab ICS CERT, ChengBin Wang de ZheJiang Guoli Security Technology, Manuel Stotz y Matthias Deeg de SySS GmbH y axt, la empresa iDefense Labs y el CNCERT/CC, además del propio Siemens, han identificado múltiples vulnerabilidades de tipo divulgación de información, corrupción de memoria, desbordamiento de búfer, configuración inadecuada, contraseñas embebidas, uso de cifrado inadecuado, XSS, comunicaciones en claro, error de carga de ficheros, inyección de comandos, etc., que afectan a diversos productos de Siemens. Un potencial atacante podría reiniciar el dispositivo, conseguir una situación de denegación de servicio, ejecutar comandos o la obtención de información sensible.

Solución: 
  • Para SCALANCE W1750D, actualizar a la nueva versión.
  • Para SINAMICS PERFECT HARMONY GH180 Drives NXG I y NXG II actualizar a NXGpro control.
  • Para SISHIP Automation de Siemens, actualizar a la versión aportada por WibuKey.
  • Para SIMATIC WinCC (ITA Portal) y SIMATIC HMI, actualizar a V15.1 Update 1 o superior
  • En cuanto a los dispositivos para los cuales Siemens no dispone de una nueva actualización, recomienda una serie de medidas de mitigación y buenas prácticas:
    • Abrir proyectos solamente provenientes de fuentes validadas.
    • Aplicar los conceptos de ciberseguridad descritos en los manuales.
    • Aplicar los principios de defensa en profundidad.
    • Establecer canales cifrados para las comunicaciones entre SIMATIC WinCC y SIMATIC PCS 7 “Encrypted communication”.
    • Restringir el acceso a los servicios web de los dispositivos afectados.
    • Restringir los accesos al puerto 161/UDP solamente a dispositivos validados.
    • Deshabilitar la funcionalidad de Lectura/Escritura en el parámetro de Fieldbus.
Detalle: 

Las vulnerabilidades de severidad crítica son las siguientes:

  • Un atacante no autenticado con acceso a la red donde se encuentra el dispositivo afectado por el puerto 10005/TCP, podría realizar acciones de reconfiguración y obtener ficheros de los proyectos que posea el dispositivo. Esta vulnerabilidad tiene impacto sobre la confidencialidad, integridad y disponibilidad del dispositivo afectado. Se ha reservado el identificador CVE-2019-10919 para esta vulnerabilidad.
  • Un atacante con acceso al servicio web del dispositivo afectado, podría realizar inyecciones de comandos sin necesidad de estar autenticado lo que podría permitir la ejecución arbitraria de comandos en el sistema operativo del dispositivo afectado, pudiendo copiar ficheros, leer configuraciones, escribir ficheros, eliminar ficheros o reiniciar el dispositivo. Se ha asignado el identificador CVE-2018-7084 para esta vulnerabilidad.
  • Un atacante con acceso local y permisos en el servidor que contiene la base de datos, podría realizar ejecuciones de comandos en el sistema. Esta vulnerabilidad tiene impacto sobre la confidencialidad, integridad y disponibilidad del sistema afectado. Se ha reservado el identificador CVE-2019-10916 para esta vulnerabilidad.
  • Un atacante no autenticado con acceso a la red donde se encuentra el dispositivo afectado que no utiliza comunicaciones cifradas, podría realizar una ejecución de código arbitrario. Esta vulnerabilidad tiene impacto sobre la confidencialidad, integridad y disponibilidad del sistema afectado. Se ha reservado el identificador CVE-2019-10922 para esta vulnerabilidad.
  • Un atacante podría enviar un paquete IRP (peticiones E/S), especialmente diseñado, que origine un desbordamiento de búfer, desembocando en una corrupción de la memoria del kernel y en una escalada de privilegios en el sistema. Se ha asignado el identificador CVE-2018-3990 para esta vulnerabilidad.
  • Un atacante podría enviar un paquete TCP, especialmente diseñado, que originen un desbordamiento de búfer y provocar una ejecución de código remoto. Se ha asignado el identificador CVE-2018-3991 para esta vulnerabilidad.

Los identificadores asignados para el resto de vulnerabilidades son: CVE-2019-10924, CVE-2019-10920, CVE-2019-10921, CVE-2018-7083, CVE-2018-16417, CVE-2018-7082, CVE-2019-6578, CVE-2019-10918, CVE-2019-6574, CVE-2018-7064, CVE-2019-6572, CVE-2019-6576, CVE-2019-6577, CVE-2019-10917 y CVE-2018-3989.

Encuesta valoración